Locked Halt TX doesn't always work. #WSJTX_config


Gary - AC6EG <gdefeyter@...>
 

While working FT8, I occasionally want to use the Halt TX button.  I've found that it only works properly about 50% of the time.  Sometimes when I click on Halt TX, the Enable TX button changes color from red to gray and my transceiver beeps, but it continues to transmit.  It will continue to xmit until the current message is completed.  I can force it to stop by clicking on Enable TX, which turns red, then re-clicking Halt TX.  Not a serious problem but wondered if anyone else is having this issue.
I am using WSJT-X version 1.8.0 and JTAlert-X version 2.10.4.   My rig is a Kenwood TS-590SG connected to a VSPE RS232 port on a desktop PC running Win7-32.  Rig control is configured via OmniRig   Serial port speed is set at  57600 baud.  Audio is supplied through a SignaLink USB.  I've used this same setup for years while operating JT65 & JT9 and never had this problem.

Gary - AC6EG


Mike Black
 

Do you find this happening when you double-click an entry and then hit Halt?  Like you're trying to tail end a QSO or set up split?

Others have reported this problem.

de Mike W9MDB


On Saturday, November 18, 2017, 9:33:07 AM CST, Gary - AC6EG <gdefeyter@...> wrote:


While working FT8, I occasionally want to use the Halt TX button.  I've found that it only works properly about 50% of the time.  Sometimes when I click on Halt TX, the Enable TX button changes color from red to gray and my transceiver beeps, but it continues to transmit.  It will continue to xmit until the current message is completed.  I can force it to stop by clicking on Enable TX, which turns red, then re-clicking Halt TX.  Not a serious problem but wondered if anyone else is having this issue.
I am using WSJT-X version 1.8.0 and JTAlert-X version 2.10.4.   My rig is a Kenwood TS-590SG connected to a VSPE RS232 port on a desktop PC running Win7-32.  Rig control is configured via OmniRig   Serial port speed is set at  57600 baud.  Audio is supplied through a SignaLink USB.  I've used this same setup for years while operating JT65 & JT9 and never had this problem.

Gary - AC6EG


Gary - AC6EG <gdefeyter@...>
 

It happened to me several times yesterday but today I can't make it NOT work.  If I double click an entry or initiate a CQ and immediately click Halt TX, the rig stops transmitting as expected.  Maybe this only happens on Fridays!  It will probably happen again at some point in the future and I will try to be more precise in observing when this failure occurs. 

I'm curious as to why there even needs to be a Halt TX button.  Seems like clicking the Enable TX button while you are transmitting should stop any transmission, but it does not.  The red Enable TX button turns gray but the rig continues to xmit. 

Gary - AC6EG


Mike Black
 

There's a difference.  Clicking Enable to disable while transmitting continues transmitting....indicating you don't want to transmit next cycle.  Halt stops the transmission likely indicating "oops...didn't mean to do that".

de Mike W9MDB


On Saturday, November 18, 2017, 1:27:44 PM CST, Gary - AC6EG <gdefeyter@...> wrote:


It happened to me several times yesterday but today I can't make it NOT work.  If I double click an entry or initiate a CQ and immediately click Halt TX, the rig stops transmitting as expected.  Maybe this only happens on Fridays!  It will probably happen again at some point in the future and I will try to be more precise in observing when this failure occurs. 

I'm curious as to why there even needs to be a Halt TX button.  Seems like clicking the Enable TX button while you are transmitting should stop any transmission, but it does not.  The red Enable TX button turns gray but the rig continues to xmit. 

Gary - AC6EG


Dave Garber <ve3wej@...>
 

Why are you not using the internal sub codec and db9 direct.   Maybe there is a buffer delay between your radio. And software going via the vspe port

On Nov 18, 2017 10:33 AM, "Gary - AC6EG" <gdefeyter@...> wrote:

While working FT8, I occasionally want to use the Halt TX button.  I've found that it only works properly about 50% of the time.  Sometimes when I click on Halt TX, the Enable TX button changes color from red to gray and my transceiver beeps, but it continues to transmit.  It will continue to xmit until the current message is completed.  I can force it to stop by clicking on Enable TX, which turns red, then re-clicking Halt TX.  Not a serious problem but wondered if anyone else is having this issue.
I am using WSJT-X version 1.8.0 and JTAlert-X version 2.10.4.   My rig is a Kenwood TS-590SG connected to a VSPE RS232 port on a desktop PC running Win7-32.  Rig control is configured via OmniRig   Serial port speed is set at  57600 baud.  Audio is supplied through a SignaLink USB.  I've used this same setup for years while operating JT65 & JT9 and never had this problem.

Gary - AC6EG



tom
 

Gary,
I have exactly the same rig and station setup software versions that you do.  The only time Halt TX doesn’t work is if I try to halt at the same instant that the rig keys.  The rig xmits but the Enable button is white.  I attribute that mostly to operator error as I know when it will do that.  That happens about 1% of the time.  The only difference in setup is I run serial and USB at 9600.  Plenty fast and rock solid.  
73,
Tom
KE0ABA


On Nov 18, 2017, at 1:27 PM, Gary - AC6EG <gdefeyter@...> wrote:

It happened to me several times yesterday but today I can't make it NOT work.  If I double click an entry or initiate a CQ and immediately click Halt TX, the rig stops transmitting as expected.  Maybe this only happens on Fridays!  It will probably happen again at some point in the future and I will try to be more precise in observing when this failure occurs. 

I'm curious as to why there even needs to be a Halt TX button.  Seems like clicking the Enable TX button while you are transmitting should stop any transmission, but it does not.  The red Enable TX button turns gray but the rig continues to xmit. 

Gary - AC6EG


Gary - AC6EG <gdefeyter@...>
 

On Sat, Nov 18, 2017 at 11:33 am, Michael Black wrote:
There's a difference.  Clicking Enable to disable while transmitting continues transmitting....indicating you don't want to transmit next cycle.  Halt stops the transmission likely indicating "oops...didn't mean to do that".
 
de Mike W9MDB
Thanks for that explanation, Mike.  I'd forgotten the Enable TX button worked that way.  Also emphasizes the need for a Halt TX button that works reliably. The oops could be that you've changed bands but forgot to change antennas.  I've used it mostly to stop TX when I see that a station I've been calling has answered another caller on a different frequency. The auto sequence feature won't stop my TX if that happens.  I'm not a big fan of this idea of everybody using split frequencies when operating digital modes.

Gary - AC6EG 

 
On Saturday, November 18, 2017, 1:27:44 PM CST, Gary - AC6EG <gdefeyter@...> wrote:
 
 
It happened to me several times yesterday but today I can't make it NOT work.  If I double click an entry or initiate a CQ and immediately click Halt TX, the rig stops transmitting as expected.  Maybe this only happens on Fridays!  It will probably happen again at some point in the future and I will try to be more precise in observing when this failure occurs. 

I'm curious as to why there even needs to be a Halt TX button.  Seems like clicking the Enable TX button while you are transmitting should stop any transmission, but it does not.  The red Enable TX button turns gray but the rig continues to xmit. 

Gary - AC6EG


Gary - AC6EG <gdefeyter@...>
 

On Sat, Nov 18, 2017 at 04:51 pm, Dave Garber wrote:
Why are you not using the internal sub codec and db9 direct.   Maybe there is a buffer delay between your radio. And software going via the vspe port

 
The problem could very well be due to a buffer delay.  I think I'm going to take Tom's suggestion (KE0ABA) and slow the serial port baud rate down to 9600 and see if that makes any difference.  If this is an uncommon problem I may need to simplify my setup.  The SignaLink USB is no doubt unnecessary, but I like being able to adjust RX & TX audio with the twist of a knob and I believe it has a sound card that is superior to the one built into the TS-590.    If lowering the baud rate doesn't work, I may have to consider the elimination of VSPE, but it has been very useful to be able to share a single serial port with multiple programs.

Gary - AC6EG


Gary - AC6EG <gdefeyter@...>
 

On Sat, Nov 18, 2017 at 04:52 pm, tom wrote:
 
Gary,
I have exactly the same rig and station setup software versions that you do.  The only time Halt TX doesn’t work is if I try to halt at the same instant that the rig keys.  The rig xmits but the Enable button is white.  I attribute that mostly to operator error as I know when it will do that.  That happens about 1% of the time.  The only difference in setup is I run serial and USB at 9600.  Plenty fast and rock solid.  
73,
Tom
KE0ABA
Thanks Tom,  I'm going to try using a 9600 baud port setting.  It has the added advantage of being the default used by the TS-590 and will not have to be reconfigured it I ever need to reset the rig.

Gary - AC6EG


Gary - AC6EG <gdefeyter@...>
 

FYI, reducing the baud rate to 9600 hasn't made any difference.  About 20% of the time the Halt TX button turns off the Enable TX button and causes my rig to beep with the expected .. _ , but continues to transmit. To get it to stop I have to click the Enable TX button, which turns red, and then click Halt TX again.
Simplifying my setup also made no difference. I eliminated VSPE and OmniRig and used a direct connection to a RS232 port.  I chose TS590SG as the rig in the WSJT-X set-up menu.  The program works perfectly except for this occasional loss of the Halt TX function. Fortunately this is a minor problem and I know what to do when this happens. I'm beginning to think this is due to a problem with the rig itself. It appears to be receiving the Halt TX command, because it responds with the appropriate beep code.
Many thanks to you who offered suggestions!

Gary - AC6EG  


Gary - AC6EG <gdefeyter@...>
 

Problem Solved!  My RS-232 serial port Flow Control had been set to Hardware.    I changed Flow Control to None, and now the Halt TX button in WSJT-X works every time.

Gary - AC6EG