locked Ubuntu -- Hamlib error: IO error while opening connection to rig #WSJTX_config


Don - KM4UDX
 

Hello!  Trying to get WSJTX cat control working with my uBITX radio on my new AtomicPi (like a RaspberryPi but not as friendly, haha.). 

The audio from the uBITX via a sound card dongle via a USB hub into the AtomicPi to WSJT-X works great.  I get decodes!!  So audio input/decodes/etc. is all good there.

The issue is cat control for TX and freq changing, etc.   I've tried very option, of five, in the Serial Port dropdown. None of them enabled  cat control. The error is the std msg


The same uBITX radio works GREAT under WSJTX/Fldigi/etc. cat control on my win10 laptop using the trusted Yaesu FT-817 Rig setting.  I just copied the other parameters for baud, bits, etc. from the Win10 to the Ubunto.  But still no love.  See screen cap below.

I'm sure the problem is I don't know anything about linux/ubuntu. Like zero.  I'm thrilled that I got ubuntu up and working on the AtomicPi, and the ubunto desktop is great. (yes, this is my FIRST non-windows experience..hahah)  All on a $38 little board computer. But anyway, the ubuntu seems to run just fine on the board. But, while wsjt-x hears the uBITX USB audio just fine, it will not control and do the TX thing. ..so...help!   I'm sure I've done something simple and stupid (my specialty, haha).

WSJTX version 2.0.1

Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

km4udx@km4udx-MF-001:~$ uname -r
4.18.0-20-generic

[audio decodes work great as is, just fyi]

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 2: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Device [USB Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 


Thank you all so much for any help!

Don
km4udx
 


Karza <kari.sillanmaki@...>
 

Hi Don,

On 05/30/2019 04:40 AM, Don - KM4UDX wrote:
Hello! Trying to get WSJTX cat control working with my uBITX radio on my new AtomicPi (like a RaspberryPi but not as friendly, haha.).
...

Make sure your user-id is a member of the 'dialout' group.

To check:

* open terminal
* type command "id | grep dialout" ( without the quotemarks )
This command should return a string with groupnumbers and -names
one of which is 'dialout'.

If nothing is returned by the command then you need to add your username
to the 'dialout' group with command "sudo usermod -aG dialout km4udx".
Then log out and log in again ( or even reboot if you are used to do things like in Windows ;).

HTH & 73 de Kari oh2gqc


Bill Somerville
 

On 30/05/2019 02:40, Don - KM4UDX wrote:
Hello!  Trying to get WSJTX cat control working with my uBITX radio on my new AtomicPi (like a RaspberryPi but not as friendly, haha.). 

The audio from the uBITX via a sound card dongle via a USB hub into the AtomicPi to WSJT-X works great.  I get decodes!!  So audio input/decodes/etc. is all good there.

The issue is cat control for TX and freq changing, etc.   I've tried very option, of five, in the Serial Port dropdown. None of them enabled  cat control. The error is the std msg


The same uBITX radio works GREAT under WSJTX/Fldigi/etc. cat control on my win10 laptop using the trusted Yaesu FT-817 Rig setting.  I just copied the other parameters for baud, bits, etc. from the Win10 to the Ubunto.  But still no love.  See screen cap below.

Hi Don,

I suspect you are not selecting the correct serial port device for CAT in WSJT-X. Your screen capture shows "USB", that is definitely incorrect. I would guess that /dev/ttyUSB0 is the right one, that would be a USB to serial interface.

You also need to add your user to the 'dialout' group to be able to access serial devices:

sudo adduser $USER dialout

You must log out your desktop session and log back in for that to take effect, or simply reboot.

73
Bill
G4WJS.


Don - KM4UDX
 

Hello Kari!  I did the following (trying to flow your guidnace).

km4udx@km4udx-MF-001:~$ id | grep dialout

[got nothing back as you suggested might be the case, so on to the next step]

km4udx@km4udx-MF-001:~$ sudo usermod -aG dialout km4udx
[sudo] password for km4udx: 
km4udx@km4udx-MF-001:~$ 

[now to reboot]


Don - KM4UDX
 

So this is good news...I have access to dialout! 

km4udx@km4udx-MF-001:~$ sudo adduser $USER dialout
The user `km4udx' is already a member of `dialout'.

So now I will go back to trying all the options for serial usb dropdown...


Don - KM4UDX
 
Edited

Bill and Karza -- you are great!  Got added to the dialout group (what a secret!), upgraded something from 18.10 from 18.04, selected the correct port (pure trial and error, mostly error), then played with levels, and presto (as if it was actually easy, which it is not, but we move on..haha!).  In the screen cap below, you will notice a complete QSO!  That means that the entire value change (I love that business talk) was integrated and operational functional. Meaning the while thing...ubitx radio, antenna, ubuntu, sound dongle, rig control, atomicPi, usb hub, mouse, keyboard, wifi, all worked as one...I feel like my head is going to explode from all the new stuff ubuntu (is that how you spell it? haha) I've had to jam into my bean. But here we are. 

true story: I had to lookup how to log out.  I just wanted to confess that and get it off my chest. hahah

Thank you!!!!

Now flush with this success...I'm moving on to getting Fldigi working for the rest of the digital modes..Can I ask you guys questions on Fldigi, or should I find another group? Now that sounds weird...but you know what I mean...