Can't update to 2.0,0 from xxx.rc4 on Debian 9 Stretch #install


mike <ipaforme@...>
 

I think I met all dependencies on the list from the INSTALL readme except ONE!  (it's always something).
That would be the gfortran-4.8.2  'or newer'.  I can install 4.6.3.0-4 but since it's too old I haven't.  Instead
I have gfortran-6 (6.3.0-18+deb9u1 ) and gfortran-6-aarch64-linux-gnu but CMake complains about no Fortran compiler.
I tried specifying the path to the gfortran-6 file with the 'FC' variable but with the same result.  No success.  It wants
the plain gfortran version.  I wish Debian would release a 'dist-upgrade', I think it's about due.  I seemed to do OK adding the other dependencies manually, like I did to build .rc4.

It's normally so damn stable I don't want to leave it. (debian that is ..) 

TIA for any tips.   73,

Mike


Bill Somerville
 

On 13/12/2018 19:35, mike wrote:
I tried specifying the path to the gfortran-6 file with the 'FC' variable but with the same result.  No success.  It wants
the plain gfortran version.
Hi Mike,

you can hint the Fortran compiler to CMake by settings the CMAKE_Fortran_COMPILER variable on teh CMake configuration pass:

cmake -D CMAKE_Fortran_COMPILER=gfortran-6 ...


mike <ipaforme@...>
 




    Update:   I actually tried to install the new 2.0 release without fixing the gfortran dependency, I  just used the gfortran-6
version shown below, and WSJTX installed with no reported errors on Debian Stretch.

    No other problems for me other than being a total newbie to digital and ham radio in general. 

Happy Holidays and 73,

Mike

On 12/13/18 11:35 AM, mike via Groups.Io wrote:
I think I met all dependencies on the list from the INSTALL readme except ONE!  (it's always something).
That would be the gfortran-4.8.2  'or newer'.  I can install 4.6.3.0-4 but since it's too old I haven't.  Instead
I have gfortran-6 (6.3.0-18+deb9u1 ) and gfortran-6-aarch64-linux-gnu but CMake complains about no Fortran compiler.
I tried specifying the path to the gfortran-6 file with the 'FC' variable but with the same result.  No success.  It wants
the plain gfortran version.  I wish Debian would release a 'dist-upgrade', I think it's about due.  I seemed to do OK adding the other dependencies manually, like I did to build .rc4.

It's normally so damn stable I don't want to leave it. (debian that is ..) 

TIA for any tips.   73,

Mike


mike <ipaforme@...>
 

Thanks for that, Bill.

    I just decided to ignore the warning and I had installed the CMake files that were in the INSTALL instructions - that may have
done it.

    Installed fine with no errors.

    Thanks again and Happy Holidays!

73.

Mike

On 12/17/18 8:31 AM, Bill Somerville wrote:
On 13/12/2018 19:35, mike wrote:
I tried specifying the path to the gfortran-6 file with the 'FC' variable but with the same result.  No success.  It wants
the plain gfortran version.
Hi Mike,

you can hint the Fortran compiler to CMake by settings the CMAKE_Fortran_COMPILER variable on teh CMake configuration pass:

cmake -D CMAKE_Fortran_COMPILER=gfortran-6 ...




N9JCA Chris Matthews <n9jca.chris@...>
 

you could try Command

sudo apt-get -t stretch-backports install ( File Name )

Let us know if it works "Inquiring Minds Would Like To Know"

73

Chris N9JCA


" I am always doing that which I CANNOT do;
in order that I may LEARN how to do it "
On 12/13/18 7:35 PM, mike wrote:

I think I met all dependencies on the list from the INSTALL readme except ONE!  (it's always something).
That would be the gfortran-4.8.2  'or newer'.  I can install 4.6.3.0-4 but since it's too old I haven't.  Instead
I have gfortran-6 (6.3.0-18+deb9u1 ) and gfortran-6-aarch64-linux-gnu but CMake complains about no Fortran compiler.
I tried specifying the path to the gfortran-6 file with the 'FC' variable but with the same result.  No success.  It wants
the plain gfortran version.  I wish Debian would release a 'dist-upgrade', I think it's about due.  I seemed to do OK adding the other dependencies manually, like I did to build .rc4.

It's normally so damn stable I don't want to leave it. (debian that is ..) 

TIA for any tips.   73,

Mike