Date   

VS: [WSJTX] CAT control with FT-857 #general

Reino Talarmo
 

Hi Lance,

I think that it is impossible to use CAT without selecting a rig or some intermediate program/device in the Radio tab. The WSJT-X program needs to know what to send to rig for CAT as rigs are different in that respect. WSJT-X includes Hamlib and sends proper commands based on the selected rig.
Unfortunately I cannot help on the Rigblaster.

73, Reino OH3mA

 


Jeremy Stark
 

Hi,

I had some initial success with WSPR, but since then the software appears completely deaf on all modes; I think since I updated WSJT-X (it’s been a while since I played with it).

The MIDI setup volume sliders are greyed out at 0 volume, and the WSJT-X dB scale (lower left) shows 0dB all the time.



I don’t know what’s changed, and I can hear signals on the FT991A speaker.

I have tried setting the FT991A menus to various combinations as per various advice online, but am obviously missing something.

I am using MacOS 10.14.6, WSJT-X v2.3.0 0c42df, CAT control via USB (which works apart from the audio).

Does anyone have any ideas?

Thank you.

-- 
Jeremy Stark
G7BHB


Re: Rig Failure #Cat_RigControl

Walter Egenmaier <wegenmaier@...>
 

Thank you

On Tue, May 25, 2021 at 2:05 PM neil_zampella <neilz@...> wrote:

Walter,

May I suggest that you check out the "Making QSOs" section of the User Manual to learn about the exchange.  

https://www.physics.princeton.edu/pulsar/k1jt/wsjtx-doc/wsjtx-main-2.4.0.html#MAKE_QSOS

The QSO exchange is setup for a quick contact under 'weak signal' (note:  NOT low power) conditions.   This exchange has been used for years for EME and meteor scatter contacts, where a QSO can take anywhere from a few minutes to an hour or more to make.

Hope this helps.

Neil, KN3ILZ

On 5/24/2021 9:13 PM, Walter Egenmaier wrote:
It finally is working!!!   As you can see, it is working on the attachment. 
Ok, now I have to get out the manual and read the rest now that I'm connected.
Now I have to decipher the QSOs. Seems to be all in code, which I don't understand. Are all we doing is sending CQs, Grids, and 73s?
Seems like the conversations are short with little info or is there more to it? 
I should mention that I've been a Ham for 50 yrs, but I have been away from it for 40 yrs and just came back to it in OCT 2020, during COVID, so there are so many new things. Thanks for getting me working. Is there a good guide/tutorial to help me learn the rest?

Walt
WB4ZUT
73s

On Mon, May 24, 2021 at 9:48 AM wmmilton <WMMILTON@...> wrote:
Try Setting data bits to 8
Stop bits to 1 
Handshake to None and
Both DTS and RTS to High
Make sure you have the correct COM port.

On Sun, May 23, 2021 at 7:18 PM Walter Egenmaier <wegenmaier@...> wrote:
I am trying WSJTX 2.3.1 for the first time with latest N3FJP  (ACL ver 7.01), WIN 10, 64 bit laptop, and FT-991A (with internal modem).
I have never used WSJTX software before, but do use N3FJP and since it is compatible, I though I would try to set this up on my rig for FT8.
As you can see by the attachment, I have several rig failures. Any suggestions on how to fix. I am set up on COM7 using VSPE (Virtual Serial Port Emulator software) which does work with my ACL from N3FJP. The ACL software has rig control and it reads the freq on my rig perfectly. So not sure what my next step should be. 
I did get band activity that wasn't there before, so not sure how that happened. I'm on USB 7.074 MHz.
Appreciate any help to get me started. 
Walt / WB4ZUT
73s







--
Walter H. Egenmaier, O.D
EyeCare Consultants
Evansville, IN 47708
(812) 426-2020 Phone
(812) 426-2828 Fax

Attachments:



    





--
Walter H. Egenmaier, O.D
EyeCare Consultants
Evansville, IN 47708
(812) 426-2020 Phone
(812) 426-2828 Fax


Re: Rig Failure #Cat_RigControl

Walter Egenmaier <wegenmaier@...>
 

Thank you

On Tue, May 25, 2021 at 2:05 PM Reino Talarmo <reino.talarmo@...> wrote:

Hi Walt,

WSJT-X User Guide (princeton.edu) and FT8 Operating Guide v2 (g4ifb.com)

I have found those two very useful.

73, Reino OH3mA

 






--
Walter H. Egenmaier, O.D
EyeCare Consultants
Evansville, IN 47708
(812) 426-2020 Phone
(812) 426-2828 Fax


Re: Rig Failure #Cat_RigControl

William Smith
 

Others have pointed out that this isn't your grandfather's QSO, but there's also http://js8call.com which uses the same kinds of communications as FT8 but layers on keyboard-to-keyboard QSOs for more usual chatting and message passing.

73, Willie N1JBJ

On May 24, 2021, at 10:13 PM, Walter Egenmaier <wegenmaier@...> wrote:

Seems like the conversations are short with little info or is there more to it? 


2.4 GA Transmit Cycle Change? #FT8

W6XK
 

With v2.4 GA, the transmit cycle appears to be shorter in length.  With FT8, the cycle (PTT & Tones)  initiates at 2 seconds and terminates at 13 seconds.  With FT4, the cycle initiates at 2 seconds and terminates at 5 seconds.  Under prior RC versions of 2.4 and v2.3.1, the transmit cycle ran from 1-13 seconds on FT8 and 1-5 seconds on FT4.  There is no apparent effect on decoding on either end of the QSO.  Not a problem, just curious.

Vy 73, Chet W6XK


2.4.0 Hamlib CAT error with PowerSDR/TS-2000 emulation #Cat_RigControl #protocol

Sam Sjogren
 

Yesterday I upgraded to 2.4.0 final release on Windows 10 from
2.4.0-rc4, suddenly WSJT-X could not properly control PowerSDR
OpenHPSDR mRX PS v3.4.9 which I use with my ANAN-100D, using com0com
for the virtual serial port for CAT. In particular I could not
transmit (using PTT over CAT). I found that changing the radio mode
in WSJT-X from Data/Pkt to USB allowed it to work. Seems the
inclusion of the latest Hamlib between -rc4 and GA surfaced an
incompatibility with the TS-2000 emulation in PowerSDR.

Changing the CAT mode "ID as" in PowerSDR to "PowerSDR" and the rig to
"FlexRadio/ANAN PowerSDR/Thetis" in WSJT-X appears to have restored
full functionality, including setting the mode to "Data/Pkt" in
WSJT-X.

--
73,
-Sam
WB6RJH


CAT control with FT-857 #general

Lance Collister, W7GJ
 




-------- Forwarded Message --------
Subject: CAT control with FT-857 #general
Date: Mon, 24 May 2021 19:35:06 +0000
From: Lance Collister, W7GJ <w7gj@...>
Reply-To: w7gj@...
To: WSJTX@groups.io


Hello!

I am using Windows 10 with a RIGblaster Plug and Play to connect my laptop to my FT-857 transceiver.  My PTT works fine but I can't seem to get the CAT control to work. I have CAT selected on the FT-857 for the connection jack on the rear.  I thought I had it working last year, but now I get the attached error when I try to set it up on WSJT-X. I have been using it with the RADIO set to NONE, but I would like to be able to use the CAT control to set the frequency if that is possible. I would appreciate any tips or suggestions regarding a solution. I suspect maybe the connections on the DIN connectors are dirty and/or the cables have become defective.  I did use an ample amount of contact cleaner on the DIN connectors and cables when  connected things up a few weeks ago, though...I have downloaded and installed the most recent drivers from West Mountain Radio several times. I don't know if maybe I have an outdated HAMLIB file or something....

MNI TNX and VY 73, Lance

-- 
Lance Collister, W7GJ(ex WA3GPL, WA1JXN, WA1JXN/C6A, ZF2OC/ZF8, E51SIX, 3D2LR, 5W0GJ, E6M, TX5K, KH8/W7GJ, V6M, T8GJ, VK9CGJ, VK9XGJ, C21GJ, CP1GJ, S79GJ, FO/W7GJ, TX7MB)
P.O. Box 73
Frenchtown, MT   59834-0073
USA
TEL: (406) 626-5728
QTH: DN27ub
URL: http://www.bigskyspaces.com/w7gj
Skype: lanceW7GJ
2m DXCC #11/6m DXCC #815

Interested in 6m EME?  Ask me about subscribing to the Magic Band EME
email group, or just fill in the request box at the bottom of my web
page (above)!



Re: Prior Version Release Notes #general

Joe
 

Hi Larry,

Earlier portions of Release Notes were mistakenly truncated from the uploaded file.  The omission has now been corrected.

  -- 73, Joe, K1JT


#BugReport No receive after transmit - rig control disables RX on Yaesu FTDX-3000 VFO A running split #BugReport

Mark Steele
 

Version: WSJT-X 2.4.0 GA
Rig: Yaesu FTDX-3000
Mode: FT8 / FT4 tested

When transmitting using Rig Split mode, VFO-B is switched to for transmit, and the RX light for VFO begins flashing. After the TX cycle, receive is disabled until the RX button is manually pressed on the rig.

Tested on various bands and modes. Switching back to version 2.4.0-rc4 and this behavior does not happen.

Went back thru the entire WSJT-X configuration and saved. Forced a sync of VFO-A settings to VFO-B - no joy.

Mark Steele


Re: Prior Version Release Notes #general

Larry Banks
 

Thanks Charlie!
Larry / W1DYJ
 
 

Sent: Tuesday, May 25, 2021 1:22
Subject: Re: [WSJTX] Prior Version Release Notes #General
 
Hi Larry
 
 
You click on the version number you are interested in and from the options then shown you can download the relevant release notes.
 
73
 
Charlie
 
On Tue, 25 May 2021 at 06:44, Larry Banks via groups.io <larryb.w1dyj=verizon.net@groups.io> wrote:
Where can I find Release Notes for versions prior to 2.4?  They are not at
the end of the 2.4.0 notes.

73 -- Larry -- W1DYJ









QRA-65 vs. Q65 ? #Q65

Bill
 

Question:

Is QRA-65 the same as Q65 ?

My version of JT, has QRA-65 but not Q65 and checking PSK reporter it seems it is getting popular on 6 meters and I would like to try it and what frequency is it being used on ?

K2WH

P. S. - What's a hashtag anyway and why is that required to post ?


Re: Rig Failure #Cat_RigControl

neil_zampella
 

Walter,

May I suggest that you check out the "Making QSOs" section of the User Manual to learn about the exchange.  

https://www.physics.princeton.edu/pulsar/k1jt/wsjtx-doc/wsjtx-main-2.4.0.html#MAKE_QSOS

The QSO exchange is setup for a quick contact under 'weak signal' (note:  NOT low power) conditions.   This exchange has been used for years for EME and meteor scatter contacts, where a QSO can take anywhere from a few minutes to an hour or more to make.

Hope this helps.

Neil, KN3ILZ

On 5/24/2021 9:13 PM, Walter Egenmaier wrote:
It finally is working!!!   As you can see, it is working on the attachment. 
Ok, now I have to get out the manual and read the rest now that I'm connected.
Now I have to decipher the QSOs. Seems to be all in code, which I don't understand. Are all we doing is sending CQs, Grids, and 73s?
Seems like the conversations are short with little info or is there more to it? 
I should mention that I've been a Ham for 50 yrs, but I have been away from it for 40 yrs and just came back to it in OCT 2020, during COVID, so there are so many new things. Thanks for getting me working. Is there a good guide/tutorial to help me learn the rest?

Walt
WB4ZUT
73s

On Mon, May 24, 2021 at 9:48 AM wmmilton <WMMILTON@...> wrote:
Try Setting data bits to 8
Stop bits to 1 
Handshake to None and
Both DTS and RTS to High
Make sure you have the correct COM port.

On Sun, May 23, 2021 at 7:18 PM Walter Egenmaier <wegenmaier@...> wrote:
I am trying WSJTX 2.3.1 for the first time with latest N3FJP  (ACL ver 7.01), WIN 10, 64 bit laptop, and FT-991A (with internal modem).
I have never used WSJTX software before, but do use N3FJP and since it is compatible, I though I would try to set this up on my rig for FT8.
As you can see by the attachment, I have several rig failures. Any suggestions on how to fix. I am set up on COM7 using VSPE (Virtual Serial Port Emulator software) which does work with my ACL from N3FJP. The ACL software has rig control and it reads the freq on my rig perfectly. So not sure what my next step should be. 
I did get band activity that wasn't there before, so not sure how that happened. I'm on USB 7.074 MHz.
Appreciate any help to get me started. 
Walt / WB4ZUT
73s







--
Walter H. Egenmaier, O.D
EyeCare Consultants
Evansville, IN 47708
(812) 426-2020 Phone
(812) 426-2828 Fax

Attachments:





VS: [WSJTX] Rig Failure #Cat_RigControl

Reino Talarmo
 

Hi Walt,

WSJT-X User Guide (princeton.edu) and FT8 Operating Guide v2 (g4ifb.com)

I have found those two very useful.

73, Reino OH3mA

 


wspr bandhop bug #fixed

M0PWX
 

Hi Bill

 

Thought I would give you some positive feedback on the latest 2.4.0 GA build

 

It looks like for me the wspr bandhop issue causing WSJT-x to close with no error is fixed in 2.4.0GA

 

Thanks for all your (and the others in the team) hard work bringing us this great software

 

Keep up the good work

 

Thanks

 

73

 

Peter

 

M0PWX

 


Re: Prior Release Notes? #general

Karza
 

Larry,

On 24.5.2021 21.13, Larry Banks via groups.io wrote:
Where can I find Release Notes for versions prior to 2.4?  They are not at the end of the 2.4.0 notes.
try SourceForge, for example https://sourceforge.net/projects/wsjt/files/wsjtx-2.3.1/Release%20Notes.txt/download

73's de Kari, oh2gqc


Re: Microphone Icon on Win10 #FT8

Skip
 

Believe it or not the sound card it is using for the data tone is in the computer.  The radio’s sound card is used for transmitting the computer created audio.

On Tue, May 25, 2021 at 8:37 AM Joe Subich, W4TV <lists@...> wrote:

On 2021-05-25 9:21 AM, George Weller wrote:
> What I don't get is - why does wsjt-x turn the microphone on?  Is
> there some voice input function (if so, I haven't read about it).

The "microphone" icon represents *ANY* audio input.  WSJTX is turning
on the input to the sound card (even if it is built into your rig) in
order to *receive*.  It needs to get its audio into the computer!

73,

    ... Joe, W4TV


On 2021-05-25 9:21 AM, George Weller wrote:
> Thanks to repliers all.  I get what the icon does and the security issue
> it addresses.  When I record the microphone with Audacity, the icon
> turns on.  When not recording it, the icon is off.  What I don't get is
> - why does wsjt-x turn the microphone on?  Is there some voice input
> function (if so, I haven't read about it).  73
>






Re: Microphone Icon on Win10 #FT8

Joe Subich, W4TV
 

On 2021-05-25 9:21 AM, George Weller wrote:
What I don't get is - why does wsjt-x turn the microphone on? Is
there some voice input function (if so, I haven't read about it).
The "microphone" icon represents *ANY* audio input. WSJTX is turning
on the input to the sound card (even if it is built into your rig) in
order to *receive*. It needs to get its audio into the computer!

73,

... Joe, W4TV


On 2021-05-25 9:21 AM, George Weller wrote:
Thanks to repliers all.  I get what the icon does and the security issue it addresses.  When I record the microphone with Audacity, the icon turns on.  When not recording it, the icon is off.  What I don't get is - why does wsjt-x turn the microphone on?  Is there some voice input function (if so, I haven't read about it).  73


Re: Microphone Icon on Win10 #FT8

George Weller
 

Thanks to repliers all.  I get what the icon does and the security issue it addresses.  When I record the microphone with Audacity, the icon turns on.  When not recording it, the icon is off.  What I don't get is - why does wsjt-x turn the microphone on?  Is there some voice input function (if so, I haven't read about it).  73


Re: wsjt-x v2.4.0 hamlib #protocol error #protocol

Bill Somerville
 

On 25/05/2021 06:03, Sam Sjogren wrote:
I have a similar issue.  Everything worked in 2.4.0-rc4, not with today's general release.  Using an Anan-100D with CAT control configured to answer as a TS-2000, virtual com ports via com0com.  PTT via CAT is especially broken, frequency change sometimes work but slowly. The error message that pops up is attached as an image.

I've downgraded to 2.3.1 since 2.4.0-rc4 will stop working in a week anyway.  The current configuration works fine for 2.3.0, 2.3.1, 2.4.0-rc4, tested today after the failure with 2.4.0 GA.

73,
-Sam
Hi Geoff,

so I can see what is happening, put the attached file into your WSJT-X configuration files directory (on MS Windows that is the same as the log files directory, "Menu->File->Open log directory"), restart WSJT-X, run a minimal test that demonstrates the issue, then quit WSJT-X. It will have created a file on your Desktop called WSJT-X_RigControl.log , send me that file for analysis please?

Once the log file has been sent you can delete the log file and log configuration file to return ton normal operation.

73
Bill
G4WJS.

741 - 760 of 25763