Date   

locked Re: Hamlib error v2.3.0-rc3 on Mac OS #IssueReport #macOS #Cat_RigControl

Rob Freedman
 

I have also been struggling mightily with Mac OS Big Sur, USB interface III. and ICOM 7000. Worked perfectly (WSTJ-X FT-8 and WSPR) before upgrade to Big Sur. I also loaded the latest version of WSTJ-X and reloaded the FTLI drivers. I get audio and decodes, but no CAT control and get the HamLib IO error when I test CAT or hit the transmit button on WSTJ-X. I have poured through all the documentation for WSTJ-X, the MicroHam USB interface (primarily an external sound card), but have not found a solution. Has anyone run across this and solved it?
73s,
Rob WC0R


locked Re: #Cat_RigControl #Cat_RigControl

Bill Somerville
 

On 17/01/2021 19:58, KEN G4APB via groups.io wrote:
  • On Sun, Jan 17, 2021 at 07:35 PM, Bill Somerville wrote:
the script inside it must tale the passed parameter and decide what to do accordingly.

Hi Bill, now I am completely lost, I have no idea how to do that. 

73 Ken G4apb 

Hi Ken,

show us one of your existing batch files please?

73
Bill
G4WJS.


locked Re: WSPR Rx not reporting to PSK Reporter #WSJTX_config

Bill Somerville
 

On 17/01/2021 20:50, Fred wrote:
Hello all
With WSJT-x up and running I receive FT-8 and I can check PSK Reporter and quickly see the the decoded signals from my station.
When I switch to WSPR mode in WSJT-x I see the stations decoded in WSJT-x.
But I can not see any WSPR signals on PSK Reporter from my station.

I would assume that since I see the FT-8 signals are reporting correctly to PSK Reporter then everything is setup up correctly.

I just started playing with receiving WSPR on 630m
That's how I found the problem.

Any help would be great..

73
Fred KB4QZH
Hi Fred,

we do not send WSPR spots to PSK Reporter, they go to a similar service WSPRnet.org.

73
Bill
G4WJS.


locked WSPR Rx not reporting to PSK Reporter #WSJTX_config

Fred
 

Hello all
With WSJT-x up and running I receive FT-8 and I can check PSK Reporter and quickly see the the decoded signals from my station.
When I switch to WSPR mode in WSJT-x I see the stations decoded in WSJT-x.
But I can not see any WSPR signals on PSK Reporter from my station.

I would assume that since I see the FT-8 signals are reporting correctly to PSK Reporter then everything is setup up correctly.

I just started playing with receiving WSPR on 630m
That's how I found the problem.

Any help would be great..

73
Fred KB4QZH


locked Can't Adjust Audio Level in WSJT-X #FT8 #txaudio #WSJTX_config

Richard -- N7WFK
 

I recently moved and just hooked up all my gear today... I am trying to figure out why I can't adjust the Green Audio levels... when I do it on my Yaesu SCU-17 nothing happens. I am also running a Yaesu FTDX 1200 rig with the previous mentioned gear. Can anyone assist me on why it might be that I can't adjust the levels all of a sudden when before I moved and unhooked everything I was able to adjust from 30 up to 70 if need be and now it won't move.


locked Re: #Cat_RigControl #Cat_RigControl

KEN G4APB
 

  • On Sun, Jan 17, 2021 at 07:35 PM, Bill Somerville wrote:
the script inside it must tale the passed parameter and decide what to do accordingly.

Hi Bill, now I am completely lost, I have no idea how to do that. 

73 Ken G4apb 


locked Re: #GeneralGroupInfo Contest Log #GeneralGroupInfo

neil_zampella <neilz@...>
 

The contest log is actually a database table, there is no file.   You can export the entries to a file however.

As far as what's the the WSJTX_log, there is no separate 'flag', but you can take a look at what was received and sent, most contests you won't see the SNR but a 599, and so on.

Neil, KN3ILZ

On 1/17/2021 1:20 PM, Robie wrote:

When using WSJTX in a contest the program produces a page called Contest Log which displays the contacts made in the contest.  I'm looking for the location of this file. I see that they are in the regular WSJTX log.  Are they identified with some type of "flag" to separate them from regular contacts or are they also stored in a separate file somewhere?

Robie - AJ4F




locked Re: #GeneralGroupInfo Contest Log #GeneralGroupInfo

Bill Somerville
 

On 17/01/2021 19:20, Robie wrote:
When using WSJTX in a contest the program produces a page called Contest Log which displays the contacts made in the contest.  I'm looking for the location of this file. I see that they are in the regular WSJTX log.  Are they identified with some type of "flag" to separate them from regular contacts or are they also stored in a separate file somewhere?

Robie - AJ4F
Hi Robie,

they are stored in a database table. You can export them as a Cabrillo entry file from the file menu.

73
Bill
G4WJS.


locked Re: #Cat_RigControl #Cat_RigControl

Bill Somerville
 

On 17/01/2021 17:16, KEN G4APB via groups.io wrote:
Hi Bill,
I have tried placing the files everywhere, in C:/, C:/wspr/ and every path up to and including .../bin.
Am I correct in labelling the files as user_hardware.bat nnn ( where nnn is the band I expect a particular file is called from) ?
73 Ken G4apb
Hi Ken,

none of those paths will work unless they are on your PATH environment variable list. If you are using a .BAT file then it must be called user_hardware.bat and take one parameter which is the target band in meters. There is only one .BAT file, the script inside it must tale the passed parameter and decide what to do accordingly.

73
Bill
G4WJS.


locked Re: Failed to start Omni rig Com Server error

Micky Corrow
 

WSJT-X v.2.2.2, OmniRig v.1.19, Log4OMv2 v.2.11.0.0, Windows 10 Pro (latest version all updates installed)

I get the error 'Failed to start OmniRig COM server'

Funny thing is, JTDX works fine with everything, even if I start whichever app (Log4OM or JTDX) first. Just cannot get WSJT-X to work with OmniRig at all.

Long story short I tried to use WSJT-X for it's contest features during this weekend's VHF Sweepstakes since JTDX cant auto-sequence with other contesters. I use JTDX on 2 other stations along with Log4OMv2 on all 3. I haven't tried WSJT -X on the other 2 computers yet, but that is next up on the list, now that I have discovered Dark Mode on WSJT-X. I didn't know it existed (Dark Mode that is...) that is why I  was using the other FT8 app.

Thanks for any help or insight you might provide, I am off to install WSJT-X on the other 2 machines to see if it works there...

Micky K1XH


locked #GeneralGroupInfo Contest Log #GeneralGroupInfo

Robie - AJ4F
 

When using WSJTX in a contest the program produces a page called Contest Log which displays the contacts made in the contest.  I'm looking for the location of this file. I see that they are in the regular WSJTX log.  Are they identified with some type of "flag" to separate them from regular contacts or are they also stored in a separate file somewhere?

Robie - AJ4F


locked Re: #WSJTX_config #WSJTX_config

James Quick
 

Bill,

Here is ehe error file that I just sent to Apple. This is on the error when I try to run WSJTX 2.3.0-rc3. I don’t understand that I can run WSJTX 2.3.0-rc2 with no trouble. I am about ready to leave macOS Big Sur. The file is long and in text form.

73



Jim Quick / N4ULE
jimn4ule@...

On Jan 17, 2021, at 1:44 PM, Jim Quick <jimn4ule@...> wrote:

Bill the only thing I get the one I sent. I even renamed everything and started over and I got the same error. Runs 2.3.0-rc2 great.

73

<Screen Shot 2021-01-11 at 11.37.12 AM.png>

Jim Quick / N4ULE
jimn4ule@...



locked Re: Failed to start Omni rig Com Server error

N8CVW
 

I’ve had anomalous omnirig behavior, what does work for me :

- set omnirig 1.19 for ft857, radio is ft817
- set wsjtx (2.1.2 0068f9) : Data/Packet
- SDR Console (3.0.22) running External Radio

also, Airspy HF+ is the SDR

those are the essentials, SDRC will not talk to wsjtx (via omnirig) unless the ft817 is in the loop, although it’s supposed to emulate a TS2000 on its own

best 73

Paul
N8CVW

On Jan 17, 2021, at 1:16 PM, Bill Somerville <g4wjs@...> wrote:

On 17/01/2021 17:17, Micky Corrow via groups.io wrote:
Has there been a definitive answer fot this OmniRig problem?
I cannot for the life of me get WSJT-X to connect to the rig using OmniRig. I can get the app to connect just fine if I specify the rig (FT-847) directly.
Log4OMv2 connects with OmniRig just fine.

Can someone help? I have searched this group (and others) and have tried every suggestion but still no luck.

Micky K1XH
Hi Micky,

which version of Omni-Rig are you using? What error message do you get, including the details? Which version of WSJT-X are you using?

73
Bill
G4WJS.




locked Re: #WSJTX_config #WSJTX_config

James Quick
 

Bill the only thing I get the one I sent. I even renamed everything and started over and I got the same error. Runs 2.3.0-rc2 great.

73


Jim Quick / N4ULE
jimn4ule@...



On Jan 17, 2021, at 10:26 AM, Bill Somerville <g4wjs@...> wrote:

On 17/01/2021 15:24, Michael Salmi wrote:
Correct, thank you.
-- 
Mike Salmi, N9MDS 

Hi Mike,

oK, thanks. Same question to you as to Jim, N4ULE, any sign of a crash report?

73
Bill
G4WJS.






locked Re: Failed to start Omni rig Com Server error

Bill Somerville
 

On 17/01/2021 17:17, Micky Corrow via groups.io wrote:
Has there been a definitive answer fot this OmniRig problem?
I cannot for the life of me get WSJT-X to connect to the rig using OmniRig. I can get the app to connect just fine if I specify the rig (FT-847) directly.
Log4OMv2 connects with OmniRig just fine.

Can someone help? I have searched this group (and others) and have tried every suggestion but still no luck.

Micky K1XH
Hi Micky,

which version of Omni-Rig are you using? What error message do you get, including the details? Which version of WSJT-X are you using?

73
Bill
G4WJS.


locked Re: Failed to start Omni rig Com Server error

Micky Corrow
 

Has there been a definitive answer fot this OmniRig problem?
I cannot for the life of me get WSJT-X to connect to the rig using OmniRig. I can get the app to connect just fine if I specify the rig (FT-847) directly.
Log4OMv2 connects with OmniRig just fine.

Can someone help? I have searched this group (and others) and have tried every suggestion but still no luck.

Micky K1XH


locked Re: #Cat_RigControl #Cat_RigControl

KEN G4APB
 

Hi Bill, 
I have tried placing the files everywhere, in C:/, C:/wspr/ and every path up to and including .../bin.
Am I correct in labelling the files as user_hardware.bat nnn ( where nnn is the band I expect a particular file is called from) ?
73 Ken G4apb 


locked Re: suddenly getting low power output

Ken WB8UFC
 

FWIW, The screen saver coming on (Win 10) causes my Soundcard Input and Output to change to the Default device, which I don't want as I run multiple rigs concurrently, each with unique Soundcard Devices. My solution was to set the screensaver wait time to 240 minutes.

"interesting - I did find my wsjtx settings were default audio device instead of what I had set - mic and speaker, so I changed them back. I don't remember using skype or zoom on this computer or any other app that would involve audio, but perhaps at some point I did and resulted in change to default.
 
windows power plan and screen saver settings don't really stop win 10 from acting independently and ignoring them. plus the options I can affect are limited to screen saver time (doesn't bother me or affect connection to telnet), and sleep time (also shouldn't be a problem, just hit a key and wake up - again shouldn't disconnect telnet.) I can't find anything that I can do to stop win 10 from deciding to shut down or restart. never had these problems with win 7 - think MS guys may have outsmarted themselves and think they know it all.
 
Hank"


locked Re: #Cat_RigControl #Cat_RigControl

Bill Somerville
 

On 17/01/2021 15:24, KEN G4APB via groups.io wrote:
I have been trying to CAT control my mini from wsjt-x 2.3.0-rc2 using the bandhopping documented external CAT control facility to switch my QCX-mini from wspr beacon mode to normal Rx mode and back again. I created batch files (windows 7home), to send the special commands to the QCX, and running these standalone, they work fine. However, I can’t get the wsjtx to call the files. named ‘user_hardware.bat 040, user_hardware.bat 080 etc where ‘040 sets the QCX to 40m Rx mode and ‘080’ set the QCX to wspr 40m beacon mode ( wsjtx band hops to 80m but not rx’ing just to allow beacon tx).
Using Radio TS-480 (QCX-mini command structure), causes the QCX rx VFO A to change frequency ok as it hops, so I know it can control the QCX.
However, wsjtx does not seem to call my batch files each time it band hops as documented, anyone have any ideas what I am doing wrong.
73 Ken G4APB

Hi Ken,

where are you locating the batch file? I ask because the latest WSJT-X versions have a more flexible arrangement for running the file, but the original mechanism where the file had to be in the installation 'bin' directory is not necessarily going to work.

Now the file may be any executable file type, on Windows that means any file extension on the list specified by the PATHEXT environment variable. The file must be either in the current working directory from here WSJT-X is started, or in a directory included on the PATH environment variable.

73
Bill
G4WJS.


locked #Cat_RigControl #Cat_RigControl

KEN G4APB
 

I have been trying to CAT control my mini from wsjt-x 2.3.0-rc2 using the bandhopping documented external CAT control facility to switch my QCX-mini from wspr beacon mode to normal Rx mode and back again. I created batch files (windows 7home), to send the special commands to the QCX, and running these standalone, they work fine. However, I can’t get the wsjtx to call the files. named ‘user_hardware.bat 040, user_hardware.bat 080 etc where ‘040 sets the QCX to 40m Rx mode and ‘080’ set the QCX to wspr 40m beacon mode ( wsjtx band hops to 80m but not rx’ing just to allow beacon tx).
Using Radio TS-480 (QCX-mini command structure), causes the QCX rx VFO A to change frequency ok as it hops, so I know it can control the QCX.
However, wsjtx does not seem to call my batch files each time it band hops as documented, anyone have any ideas what I am doing wrong.
73 Ken G4APB

19521 - 19540 of 40087