Date   

locked Re: Why Upgrade? #FT8

Jim Shorney
 

Not to mention important bug fixes and feature enhancements.

73

-Jim
NU0C

On Wed, 3 Feb 2021 00:40:58 +0200
"Reino Talarmo" <reino.talarmo@...> wrote:

The question remains, why should I upgrade?
Bill W5EC

Hi Bill,

If you are happy with somewhat inferior performance, some missing new modes and potentially less support in future, then by all means don’t, hi!

73, Reino OH3mA


locked Re: Any Faster/Easier Way? #FT8

Karza
 

Ken,

On 2.2.2021 20.12, Ken WB8UFC wrote:
...Other than re-starting each instance whenever I am moving to a band the other instance has worked, is there a better/faster way to keep the colors working properly?
if you are running on Linux or MacOS you can use a symbolic link to use same wsjtx_log.adi for both instances.  ( Perhaps even M$-sh*t can do that... )

73's de Kari, oh2gqc


locked #Logging #logging

Ray, W4BYG <w4byg@...>
 

I'm a fairly new user of WSJT-X/JTAlert. I am using FT8 mostly, but can not get WSJT-X to talk to LOG4OM. They are supposed to be compatible. I have done all the config in both programs I can see need to be done, but apparently I'm missing something.

Also, as LOG4OM is not getting the data, is there a way to import the existing comma separated WSJTX.log file, into LOG4OM?

Is there anyone onboard who is using the same logging program, that would help me find the problem?

Your assistance would be appreciated.
Ray, W4BYG
-- 
They say a smart person learns from their mistakes.  A
wise person learns from the mistakes of others.

Virus-free. www.avg.com


locked Re: Cat Control Yaesu FTDX-5000 #Cat_RigControl

Bill Somerville
 

On 03/02/2021 00:41, Louis Alexander wrote:
Bill here is the message I am getting, " rig.c(1631):rig_set_freq return

while setting frequency".  The stack register I am referring to is the triple band stack memory recall.  

Hi Louis,

why do you need to rotate the rig's band stack registers when using WSJT-X?

73
Bill
G4WJS.


locked Re: Version 2.3.0 64 bit will not install #install

Bill Somerville
 

On 03/02/2021 00:44, Gary Liebisch wrote:
On Mon, Feb 1, 2021 at 02:28 PM, Bill Somerville wrote:
Get-FileHash $Env:UserProfile/Downloads/wsjtx-2.3.0-win64.exe
OK I did that, and yes got the same hash result as you suggested.  Also downloaded again.  Same result --what do I try next? I put Norton Security in "Silent Mode" and that did not help either.   If I remove my 2.1.2 then I have nothing that works, don't want to do that. 

 
--
Gary Liebisch
W8GEL
Powell, OH

Hi Gary,

please try removing v2.1.2, you can always install it again, the installer is here: https://sourceforge.net/projects/wsjt/files/wsjtx-2.1.2/ if you need it.

73
Bill
G4WJS.


locked Re: Automatic power up of rig #WSJTX_config

Bill Somerville
 

On 03/02/2021 00:40, Gordon GI6ATZ via groups.io wrote:
Hi Bill

The rig is an Icom 9700 and all other CAT functions seem to work OK

Gordon
GI6ATZ
Hi Gordon,

so I can see what is happening; put the attached file into your WSJT-X configuration files directory (on MS Windows that is the same as the log files directory "Menu->File->Open log directory"), then restart WSJT-X, do the minimum steps to reproduce the issue, then quit WSJT-X. You will have a new file on your Desktop called WSJT-X_RigControl.log, send me that file for analysis please (g4wjs <at> classdesign <dot> com) ?

You can delete the log file and the wsjtx_log_config.ini file once you have sent the log file.

73
Bill
G4WJS.


locked Re: Version 2.3.0 64 bit will not install #install

Gary Liebisch
 

Also nothing in the event log relating to the install attempt.
--
Gary Liebisch
W8GEL
Powell, OH


locked Re: Version 2.3.0 64 bit will not install #install

Gary Liebisch
 

On Mon, Feb 1, 2021 at 02:28 PM, Bill Somerville wrote:
Get-FileHash $Env:UserProfile/Downloads/wsjtx-2.3.0-win64.exe
OK I did that, and yes got the same hash result as you suggested.  Also downloaded again.  Same result --what do I try next? I put Norton Security in "Silent Mode" and that did not help either.   If I remove my 2.1.2 then I have nothing that works, don't want to do that. 

 
--
Gary Liebisch
W8GEL
Powell, OH


locked Re: Cat Control Yaesu FTDX-5000 #Cat_RigControl

Louis Alexander
 

Bill here is the message I am getting, " rig.c(1631):rig_set_freq return

while setting frequency".  The stack register I am referring to is the triple band stack memory recall.  


locked Re: Automatic power up of rig #WSJTX_config

Gordon GI6ATZ
 

Hi Bill

The rig is an Icom 9700 and all other CAT functions seem to work OK

Gordon
GI6ATZ


locked Re: #Cat_RigControl FT-817 Hamlib issues #Cat_RigControl

Bill Somerville
 

Hi Kevin,

Ok on the unplugged CAT cable, you did say you wanted a quick fix, hi! Some rigs are tolerant of the wrong number of stop bits.

Glad you are back up and running.

73
Bill
G4WJS.

On 03/02/2021 00:29, Kevin Utzy wrote:

Bill,

 

I feel dumb only because I should know better after all these years.  I should have tried running FT-817 Commander first to double check.  Ugg.  Sure enough the cable was unplugged.  I forgot to put it in when reconnecting the antenna.

 

I had no clue those settings were wrong.  The I have used “1” stop-bit for ever it seems for 9600 and 38400.  Handshake I always have as none.  I think I got that from N1MM recommended settings.

 

Sorry to have needlessly bothered you.  At least I can use FT-817 vs. FT-857 again!  😊

 

Thank you.

 

73, Kevin KX4KU

 

 

 

From: main@WSJTX.groups.io <main@WSJTX.groups.io> On Behalf Of Bill Somerville
Sent: Tuesday, February 2, 2021 19:16
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] #Cat_RigControl FT-817 Hamlib issues

 

On 02/02/2021 23:53, Bill Somerville wrote:

On 02/02/2021 23:47, Kevin Utzy wrote:


I am trying to run v2.3 GA with the FT-817.

73,
Kevin

KX4KU

Hi Kevin,

so I can see what is happening; put the attached file into your WSJT-X configuration files directory (on MS Windows that is the same as the log files directory "Menu->File->Open log directory"), then restart WSJT-X, do the minimum steps to reproduce the issue, then quit WSJT-X. You will have a new file on your Desktop called WSJT-X_RigControl.log, send me that file for analysis please (g4wjs <at> classdesign <dot> com) ?

You can delete the log file and the wsjtx_log_config.ini file once you have sent the log file.

73
Bill
G4WJS.

Hi Kevin,

thanks for the log. Your rig is not responding to any CAT commands. Check that your CAT cable is correctly plugged in and the mini-DIN plug has no bent pins. Check that COM3 is the right serial port, and the CAT baud rate on your rig really is 9600. You have selected "Settings->Radio->Stop bits->One" which is wrong for your rig, you can select "Default" for "Data bits", "Stop bits", and "Handshake".

73



locked Re: #Cat_RigControl FT-817 Hamlib issues #Cat_RigControl

Kevin Utzy
 

Bill,

 

I feel dumb only because I should know better after all these years.  I should have tried running FT-817 Commander first to double check.  Ugg.  Sure enough the cable was unplugged.  I forgot to put it in when reconnecting the antenna.

 

I had no clue those settings were wrong.  The I have used “1” stop-bit for ever it seems for 9600 and 38400.  Handshake I always have as none.  I think I got that from N1MM recommended settings.

 

Sorry to have needlessly bothered you.  At least I can use FT-817 vs. FT-857 again!  😊

 

Thank you.

 

73, Kevin KX4KU

 

 

 

From: main@WSJTX.groups.io <main@WSJTX.groups.io> On Behalf Of Bill Somerville
Sent: Tuesday, February 2, 2021 19:16
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] #Cat_RigControl FT-817 Hamlib issues

 

On 02/02/2021 23:53, Bill Somerville wrote:

On 02/02/2021 23:47, Kevin Utzy wrote:


I am trying to run v2.3 GA with the FT-817.

73,
Kevin

KX4KU

Hi Kevin,

so I can see what is happening; put the attached file into your WSJT-X configuration files directory (on MS Windows that is the same as the log files directory "Menu->File->Open log directory"), then restart WSJT-X, do the minimum steps to reproduce the issue, then quit WSJT-X. You will have a new file on your Desktop called WSJT-X_RigControl.log, send me that file for analysis please (g4wjs <at> classdesign <dot> com) ?

You can delete the log file and the wsjtx_log_config.ini file once you have sent the log file.

73
Bill
G4WJS.

Hi Kevin,

thanks for the log. Your rig is not responding to any CAT commands. Check that your CAT cable is correctly plugged in and the mini-DIN plug has no bent pins. Check that COM3 is the right serial port, and the CAT baud rate on your rig really is 9600. You have selected "Settings->Radio->Stop bits->One" which is wrong for your rig, you can select "Default" for "Data bits", "Stop bits", and "Handshake".

73


locked Re: #Cat_RigControl FT-817 Hamlib issues #Cat_RigControl

Bill Somerville
 

On 02/02/2021 23:53, Bill Somerville wrote:
On 02/02/2021 23:47, Kevin Utzy wrote:

I am trying to run v2.3 GA with the FT-817.

73,
Kevin

KX4KU

Hi Kevin,

so I can see what is happening; put the attached file into your WSJT-X configuration files directory (on MS Windows that is the same as the log files directory "Menu->File->Open log directory"), then restart WSJT-X, do the minimum steps to reproduce the issue, then quit WSJT-X. You will have a new file on your Desktop called WSJT-X_RigControl.log, send me that file for analysis please (g4wjs <at> classdesign <dot> com) ?

You can delete the log file and the wsjtx_log_config.ini file once you have sent the log file.

73
Bill
G4WJS.

Hi Kevin,

thanks for the log. Your rig is not responding to any CAT commands. Check that your CAT cable is correctly plugged in and the mini-DIN plug has no bent pins. Check that COM3 is the right serial port, and the CAT baud rate on your rig really is 9600. You have selected "Settings->Radio->Stop bits->One" which is wrong for your rig, you can select "Default" for "Data bits", "Stop bits", and "Handshake".

73


locked Re: #Cat_RigControl FT-817 Hamlib issues #Cat_RigControl

Bill Somerville
 

On 02/02/2021 23:47, Kevin Utzy wrote:

I am trying to run v2.3 GA with the FT-817.

73,
Kevin

KX4KU
Hi Kevin,

so I can see what is happening; put the attached file into your WSJT-X configuration files directory (on MS Windows that is the same as the log files directory "Menu->File->Open log directory"), then restart WSJT-X, do the minimum steps to reproduce the issue, then quit WSJT-X. You will have a new file on your Desktop called WSJT-X_RigControl.log, send me that file for analysis please (g4wjs <at> classdesign <dot> com) ?

You can delete the log file and the wsjtx_log_config.ini file once you have sent the log file.

73
Bill
G4WJS.


locked Re: #Cat_RigControl FT-817 Hamlib issues #Cat_RigControl

Kevin Utzy
 

I am trying to run v2.3 GA with the FT-817.

73,
Kevin

KX4KU


locked Re: Cat Control Yaesu FTDX-5000 #Cat_RigControl

Bill Somerville
 

On 02/02/2021 23:31, Louis Alexander wrote:
Version 2.2.0 worked perfectly but somewhere after that rc2 and rc3 and now 2.3.0 do not work properly with the rig control of the radio.  If you use the stack register you will get ham lib errors and will have to reload the software and start all over again.  Even version 1.8 worked perfectly.  What changes were made that effect the Yaesu FT-5000? Using a SignaLink interface also. Maybe that is the problem??
Hi Louis,

what errors do you get (include details please) when you "use the stack register", and what does "use the stack register" entail?

What software do you need to reload?

73
Bill
G4WJS.


locked Cat Control Yaesu FTDX-5000 #Cat_RigControl

Louis Alexander
 

Version 2.2.0 worked perfectly but somewhere after that rc2 and rc3 and now 2.3.0 do not work properly with the rig control of the radio.  If you use the stack register you will get ham lib errors and will have to reload the software and start all over again.  Even version 1.8 worked perfectly.  What changes were made that effect the Yaesu FT-5000? Using a SignaLink interface also. Maybe that is the problem??


locked Re: #Cat_RigControl FT-817 Hamlib issues #Cat_RigControl

Bill Somerville
 

On 02/02/2021 23:22, Kevin Utzy wrote:
I am getting the same as OP.

Windows 10, FT-817ND, 9600 bps.

"The error is Hamlib Communication timed out

rig.c (1826):rig_get_freq return while getting current frequency."

Hope it is a quick fix!

73, Kevin, KX4KU
Hi Kevin,

which version of WSJT-X are you using?

73
Bill
G4WJS.


locked Re: #Cat_RigControl FT-817 Hamlib issues #Cat_RigControl

Kevin Utzy
 

I am getting the same as OP. 

Windows 10, FT-817ND, 9600 bps.

"The error is Hamlib Communication timed out

rig.c (1826):rig_get_freq return while getting current frequency."

Hope it is a quick fix!

73, Kevin, KX4KU


locked Re: Automatic power up of rig #WSJTX_config

Bill Somerville
 

On 02/02/2021 23:14, David Ross wrote:
Hi Bill thanks for the file
I placed it into the log directory and it still will not power up the radio
I am using the new release V2.3.0 0c42df
I ask Gordon GI6ATZ to try and he got the same result.
Is there any thing else I can try
Attached a picture of were I placed the file.
Many thanks
David Gi4sna
Hi David,

which rig do you have, and is it working correctly for other CAT functions?

73
Bill
G4WJS.

15601 - 15620 of 37047