Date   

locked Re: Data Logging

Ed Bloom, KD9FRQ
 

Ah.....yes. Thank you.

On 4/13/2020 4:58 PM, Dave Garber wrote:

perhaps you meant to send this to an aprs group????


Dave Garber
VE3WEJ / VE3IE


On Mon, Apr 13, 2020 at 12:58 PM Ed Bloom, KD9FRQ via groups.io <ewbloom=verizon.net@groups.io> wrote:
I am using a DRAWS on a Pi as my computer.

I am seeing mobile stations move but I am not seeing the data in the
View > Incoming Data > TNC Data Only screen.

Am I looking for it in the correct spot?

I am wanting to see what the general receive pattern is for the new
antenna (it will get moved higher when the weather breaks) by only
tracking the data I receive over the air.

Thanks,

Ed, KD9FRQ




    



locked Re: HRD and split operation

Amir K9CHP
 

Try running the HRD CAT program in the background, might help. 

--

73 de Amir K9CHP

ARRL, Emergency Coordinator (EC)
Liverpool Amateur Repeater Club www.W2CM.org
Radio Amateurs of Greater Syracuse  www.ragsclub.org
Wilderness SAR (ret.) www.wsar.org
Eagle Valley Search Dogs (ret.) www.evdogs.org


On Mon, Apr 13, 2020, 17:23 <dk1wb@...> wrote:

Hi Milos,

thanks for your reply.

It is interesting that the issue is not limted to Kenwood but also happens with Yaesu rig.

I will claim the issue to HRD LLC and hope that they will fix it.

73 and stay healthy,

Hans, DK1WB

 

Miloš Soukup schrieb am 13.04.2020 20:48 (GMT +02:00):

Hi Hans,



I am an HRD user also.

My workaround is the opposite: I connect my FT-817 to WSJT-X directly.

I just send logged QSOs to HRD Logbook. I use WSJT-X + HRD Logbook only for
FT8.

You can try to report it to HRD.




73! de Milos, OK1FMY




 
 ---------- Původní e-mail ----------
Od: dk1wb@...
Komu: WSJTX@groups.io
Datum: 13. 4. 2020 17:58:14
Předmět: [WSJTX] HRD and split operation
"
Not sure if this is the right forum to address this issue.
I am connecting a TS590SG to the CAT interface of WSJT-X 2.1.2 through the
HRD driver of WSJT-X. HRD version is 6.7.  Using WSJT-X split functions (rig
or fake-it) does not work in this configuration. The frequency display of 
WSJT-X is changing during transmissions as it should but the TRX carrier 
frequency does not change. Then rather the TX carrier frequency is shifting
according to the split algorithm. TRX band switching by WSJT-X does work 
without problems.

When the TS590SG talks directly to WSJT-X and not through HRD the split 
function works OK. I assume that the problem lies in the HRD driver of WSJT-
X.

This is a rather old issue. My work around so far was not to use split.

Is HRD Software LLC to blame for this problem?
73, Hans (DK1WB)

"




locked Re: Compiling for arm64 Issue

JT Croteau <jt.tobit@...>
 

Bill, I'm running Gentoo.


On Mon, Apr 13, 2020, 3:20 PM Bill Somerville <g4wjs@...> wrote:
On 13/04/2020 15:58, JT Croteau wrote:
> Sucess!  Thank you so much Bill.
>
> # file wsjtx
> wsjtx: ELF 64-bit LSB shared object, ARM aarch64, version 1
> (GNU/Linux), dynamically linked, interpreter
> /lib/ld-linux-aarch64.so.1, for GNU/Linux 3.7.0, not stripped
>
> 73 N1ESE

Hi JT,

well done! What Linux distribution are you using?

73
Bill
G4WJS.



locked Re: Data Logging

Dave Garber <ve3wej@...>
 

perhaps you meant to send this to an aprs group????


Dave Garber
VE3WEJ / VE3IE


On Mon, Apr 13, 2020 at 12:58 PM Ed Bloom, KD9FRQ via groups.io <ewbloom=verizon.net@groups.io> wrote:
I am using a DRAWS on a Pi as my computer.

I am seeing mobile stations move but I am not seeing the data in the
View > Incoming Data > TNC Data Only screen.

Am I looking for it in the correct spot?

I am wanting to see what the general receive pattern is for the new
antenna (it will get moved higher when the weather breaks) by only
tracking the data I receive over the air.

Thanks,

Ed, KD9FRQ



locked Re: Mode Change in split operation

IU1JVO
 

Hi Bill,

RIG: Yaesu FT-911

Cat Control:
Serial Port: (The Enhanced Serial port of Rig)
Parameters:
Rate: 4800
Data Bits: Default
Stop Bits: Default
Handshake: Default

No Force for Control Lines


73
IU1JVO
Giuliano.



Il 13/04/2020 22:50, Bill Somerville ha scritto:

Hi Giuliano,

thanks for that. What are the settings on the left hand side of the "Settings->Radio" panel please?

73
Bill
G4WJS.

On 13/04/2020 21:48, IU1JVO wrote:

Hi Bill,

My Rig is FT-911A. De Settings are:

PTT Method: CAT
Mode: Data/Pkt
Split Operation: Rig

VFO-A mode is correcly changed from previosly set (LSB) but not the VFO-B set, that did remain LSB.

73 de IU1JVO
Giuliano.


Il 13/04/2020 22:18, Bill Somerville ha scritto:
On 13/04/2020 18:59, IU1JVO wrote:
Hi,
The rig is already directly connected to WSJT-X.
Is not a real problem, I need to set the VFO-B to the correct mode before. Then WSJT-X connected to the rig, set time by time the frequency needed.

Thanks.

73 de IU1JVO

Hi Giuliano,

what rig do you have, and what settings do you have in WSJT-X on the left hand side of the "Settings->Radio" panel?

73
Bill
G4WJS.




    


locked Re: HRD and split operation

dk1wb
 

Hi Milos,

thanks for your reply.

It is interesting that the issue is not limted to Kenwood but also happens with Yaesu rig.

I will claim the issue to HRD LLC and hope that they will fix it.

73 and stay healthy,

Hans, DK1WB

 

Miloš Soukup schrieb am 13.04.2020 20:48 (GMT +02:00):

Hi Hans,



I am an HRD user also.

My workaround is the opposite: I connect my FT-817 to WSJT-X directly.

I just send logged QSOs to HRD Logbook. I use WSJT-X + HRD Logbook only for
FT8.

You can try to report it to HRD.




73! de Milos, OK1FMY




 
 ---------- Původní e-mail ----------
Od: dk1wb@...
Komu: WSJTX@groups.io
Datum: 13. 4. 2020 17:58:14
Předmět: [WSJTX] HRD and split operation
"
Not sure if this is the right forum to address this issue.
I am connecting a TS590SG to the CAT interface of WSJT-X 2.1.2 through the
HRD driver of WSJT-X. HRD version is 6.7.  Using WSJT-X split functions (rig
or fake-it) does not work in this configuration. The frequency display of 
WSJT-X is changing during transmissions as it should but the TRX carrier 
frequency does not change. Then rather the TX carrier frequency is shifting
according to the split algorithm. TRX band switching by WSJT-X does work 
without problems.

When the TS590SG talks directly to WSJT-X and not through HRD the split 
function works OK. I assume that the problem lies in the HRD driver of WSJT-
X.

This is a rather old issue. My work around so far was not to use split.

Is HRD Software LLC to blame for this problem?
73, Hans (DK1WB)

"



locked Re: FT4 QSO procedure #QSO_practices #FT4

Hasan Schiers N0AN
 

It is very common on both FT4 and FT8. I have some callers start with a signal report and no initial call. 
It still works and they end up in the log.
73, N0AN
Hasan


On Mon, Apr 13, 2020 at 10:35 AM <K7GQ@...> wrote:
Seeing other caller while in a QSO is common to both FT4 and FT8, and should you wish, you'd simply click on another caller without wasting time calling CQ.


locked Re: Mode Change in split operation

Bill Somerville
 

Hi Giuliano,

thanks for that. What are the settings on the left hand side of the "Settings->Radio" panel please?

73
Bill
G4WJS.

On 13/04/2020 21:48, IU1JVO wrote:

Hi Bill,

My Rig is FT-911A. De Settings are:

PTT Method: CAT
Mode: Data/Pkt
Split Operation: Rig

VFO-A mode is correcly changed from previosly set (LSB) but not the VFO-B set, that did remain LSB.

73 de IU1JVO
Giuliano.


Il 13/04/2020 22:18, Bill Somerville ha scritto:
On 13/04/2020 18:59, IU1JVO wrote:
Hi,
The rig is already directly connected to WSJT-X.
Is not a real problem, I need to set the VFO-B to the correct mode before. Then WSJT-X connected to the rig, set time by time the frequency needed.

Thanks.

73 de IU1JVO
Hi Giuliano,

what rig do you have, and what settings do you have in WSJT-X on the left hand side of the "Settings->Radio" panel?

73
Bill
G4WJS.


locked Re: Mode Change in split operation

IU1JVO
 

Hi Bill,

My Rig is FT-911A. De Settings are:

PTT Method: CAT
Mode: Data/Pkt
Split Operation: Rig

VFO-A mode is correcly changed from previosly set (LSB) but not the VFO-B set, that did remain LSB.

73 de IU1JVO
Giuliano.


Il 13/04/2020 22:18, Bill Somerville ha scritto:

On 13/04/2020 18:59, IU1JVO wrote:
Hi,
The rig is already directly connected to WSJT-X.
Is not a real problem, I need to set the VFO-B to the correct mode before. Then WSJT-X connected to the rig, set time by time the frequency needed.

Thanks.

73 de IU1JVO

Hi Giuliano,

what rig do you have, and what settings do you have in WSJT-X on the left hand side of the "Settings->Radio" panel?

73
Bill
G4WJS.



    


locked Re: Compiling for arm64 Issue

Bill Somerville
 

On 13/04/2020 15:58, JT Croteau wrote:
Sucess! Thank you so much Bill.

# file wsjtx
wsjtx: ELF 64-bit LSB shared object, ARM aarch64, version 1
(GNU/Linux), dynamically linked, interpreter
/lib/ld-linux-aarch64.so.1, for GNU/Linux 3.7.0, not stripped

73 N1ESE
Hi JT,

well done! What Linux distribution are you using?

73
Bill
G4WJS.


locked Re: Mode Change in split operation

Bill Somerville
 

On 13/04/2020 18:59, IU1JVO wrote:
Hi,
The rig is already directly connected to WSJT-X.
Is not a real problem, I need to set the VFO-B to the correct mode before. Then WSJT-X connected to the rig, set time by time the frequency needed.

Thanks.

73 de IU1JVO
Hi Giuliano,

what rig do you have, and what settings do you have in WSJT-X on the left hand side of the "Settings->Radio" panel?

73
Bill
G4WJS.


locked Re: HRD and split operation

Miloš Soukup
 

Hi Hans,

I am an HRD user also.
My workaround is the opposite: I connect my FT-817 to WSJT-X directly.
I just send logged QSOs to HRD Logbook. I use WSJT-X + HRD Logbook only for FT8.
You can try to report it to HRD.

73! de Milos, OK1FMY

 

Not sure if this is the right forum to address this issue.
I am connecting a TS590SG to the CAT interface of WSJT-X 2.1.2 through the HRD driver of WSJT-X. HRD version is 6.7.  Using WSJT-X split functions (rig or fake-it) does not work in this configuration. The frequency display of WSJT-X is changing during transmissions as it should but the TRX carrier frequency does not change. Then rather the TX carrier frequency is shifting according to the split algorithm. TRX band switching by WSJT-X does work without problems.

When the TS590SG talks directly to WSJT-X and not through HRD the split function works OK. I assume that the problem lies in the HRD driver of WSJT-X.

This is a rather old issue. My work around so far was not to use split.

Is HRD Software LLC to blame for this problem?
73, Hans (DK1WB)



locked Re: Error in Sound Output: An Error open the audio outout device has occurred??

Jim Brown
 

On 4/13/2020 9:10 AM, dk1wb@... wrote:
USB communication between PC and TRX is not reliable if the antenna is too close. QRP is certainly a solution but you may want to try this:
Connecting the shield of the Notebook-USB connector to station ground by means of a ground clip from a scope probe should allows you some QRO (see attached picture).
This should ALWAYS be done. Indeed, ALL equipment that is part of the station should have its chassis bonded to all other equipment in the station, and to station ground, AND every ground in our homes should be bonded together. This is fundamental good engineering practice, and in most parts of the world it is the LAW.

There is detailed advice in this set of slides for talks I've given at Pacificon, Visalia, and to multiple clubs.

http://k9yc.com/GroundingAndAudio.pdf

It is specifically written for North American building Codes (Law); differences between codes in various parts of the world are addressed in this "white paper" for professional audio and video contractors.

http://k9yc.com/SurgeXPowerGround.pdf

73, Jim K9YC


locked K3S and WSJT-X on 160M

Bob McGraw - K4TAX <rmcgraw@...>
 

I've encountered an issue which I have failed to resolve.    I'm using an Elecraft K3S on 160M.  I have WSJT-X configured to work normally and find that indeed it does for what I'll describe as normal operation.

However, I'm trying to set up to work the JA/s.   To do this I need to transmit on 1.840 and to receive on 1.908.   I have WSJT-X set in the MODE to Data/PKT which does switch the radio to the correct DATA mode.  Then in the Split Operation I have that set to NONE.    Now for the radio I have the VFO A set to 1.908 for receive and VFO B set to 1.840 for transmit.   I have SPLIT manually activated on the radio.  When I initiate and release the PTT on the radio all switches correctly.

Now the issue.  Using WSJT-X v2.1.2 I find that when I initiate TUNE the radio goes into transmit on VFO B at 1.840, there is power out, and it transmits on 1.840.  When I release TUNE the VFO B changes to 1.908.  Thus the next transmission is on 1.908 and is NOT on 1.840 as it should be.

I have tried many options and configurations without success. This includes using Fake It, Rig, None for SPLIT operation with WSJT. The operating system is Windows 10 Pro 64 bit.

From my efforts, it appears that a command is being sent to the radio to make VFO A and VFO B equal upon release of the PTT command from WSJT-X.

Your thoughts and suggestions please.

73

Bob, K4TAX


locked Re: Compiling for arm64 Issue

Dave Carlton
 

I had that same error on the MAC, I edited the file and commented out the duplicate.

On Apr 12, 2020, at 17:02, Bill Somerville <g4wjs@...> wrote:

On 12/04/2020 20:24, JT Croteau wrote:
Friends, I'm trying to compile 2.1.2 on Linux arm64 but having an
issue.  I'm wondering if anyone can help please?  arm64 is a different
platform than armhf so I can't use the binary package on my Gentoo
system.  Target hardware is a Raspberry Pi4B. Thanks

Failing here:

[ 69%] Building CXX object CMakeFiles/wsjt_qt.dir/qt_helpers.cpp.o
In file included from /home/n1ese/build/wsjtx-prefix/src/wsjtx/qt_helpers.cpp:1:
/home/n1ese/build/wsjtx-prefix/src/wsjtx/qt_helpers.hpp: In static
member function ‘static QVariant VPtr<T>::asQVariant(T*)’:
/home/n1ese/build/wsjtx-prefix/src/wsjtx/qt_helpers.hpp:77:61:
warning: ‘QVariant qVariantFromValue(const T&) [with T = void*]’ is
deprecated: Use QVariant::fromValue() instead.
[-Wdeprecated-declarations]
   77 |     return qVariantFromValue (reinterpret_cast<void *> (ptr));
      |                                                             ^
In file included from /usr/include/qt5/QtCore/qlocale.h:43,
                 from /usr/include/qt5/QtCore/qtextstream.h:46,
                 from /usr/include/qt5/QtCore/qdebug.h:49,
                 from /usr/include/qt5/QtNetwork/qabstractsocket.h:47,
                 from /usr/include/qt5/QtNetwork/qhostaddress.h:48,
                 from /usr/include/qt5/QtNetwork/QHostAddress:1,
                 from /home/n1ese/build/wsjtx-prefix/src/wsjtx/qt_helpers.hpp:9,
                 from /home/n1ese/build/wsjtx-prefix/src/wsjtx/qt_helpers.cpp:1:
/usr/include/qt5/QtCore/qvariant.h:528:17: note: declared here
  528 | inline QVariant qVariantFromValue(const T &t)
      |                 ^~~~~~~~~~~~~~~~~
In file included from /home/n1ese/build/wsjtx-prefix/src/wsjtx/qt_helpers.cpp:1:
/home/n1ese/build/wsjtx-prefix/src/wsjtx/qt_helpers.hpp: At global scope:
/home/n1ese/build/wsjtx-prefix/src/wsjtx/qt_helpers.hpp:87:10: error:
redefinition of ‘struct std::hash<QString>’
   87 |   struct hash<QString>
      |          ^~~~~~~~~~~~~
In file included from /usr/include/qt5/QtCore/qlist.h:47,
                 from /usr/include/qt5/QtCore/qhash.h:46,
                 from /usr/include/qt5/QtCore/qshareddata.h:46,
                 from /usr/include/qt5/QtNetwork/qhostaddress.h:47,
                 from /usr/include/qt5/QtNetwork/QHostAddress:1,
                 from /home/n1ese/build/wsjtx-prefix/src/wsjtx/qt_helpers.hpp:9,
                 from /home/n1ese/build/wsjtx-prefix/src/wsjtx/qt_helpers.cpp:1:
/usr/include/qt5/QtCore/qhashfunctions.h:204:1: note: previous
definition of ‘struct std::hash<QString>’
  204 | QT_SPECIALIZE_STD_HASH_TO_CALL_QHASH_BY_CREF(QString)
      | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
gmake[5]: *** [CMakeFiles/wsjt_qt.dir/build.make:106:
CMakeFiles/wsjt_qt.dir/qt_helpers.cpp.o] Error 1
gmake[5]: Leaving directory '/home/n1ese/build/wsjtx-prefix/src/wsjtx-build'
gmake[4]: *** [CMakeFiles/Makefile2:822: CMakeFiles/wsjt_qt.dir/all] Error 2
gmake[4]: Leaving directory '/home/n1ese/build/wsjtx-prefix/src/wsjtx-build'
gmake[3]: *** [Makefile:169: all] Error 2
gmake[3]: Leaving directory '/home/n1ese/build/wsjtx-prefix/src/wsjtx-build'
gmake[2]: *** [CMakeFiles/wsjtx-build.dir/build.make:78:
wsjtx-prefix/src/wsjtx-stamp/wsjtx-build] Error 2
gmake[2]: Leaving directory '/home/n1ese/build'
gmake[1]: *** [CMakeFiles/Makefile2:405: CMakeFiles/wsjtx-build.dir/all] Error 2
gmake[1]: Leaving directory '/home/n1ese/build'
gmake: *** [Makefile:101: all] Error 2

Hi JT (?),

the following patch should get you going.

73
Bill
G4WJS.

commit f769f179c816a244f91dba359ad9e0a3eb234e0a
Author: Bill Somerville <bill@...>
Date:   Sat Feb 1 23:55:18 2020 +0000

    Remove std::hash<QString> specialization for Qt >= 5.14

diff --git a/qt_helpers.hpp b/qt_helpers.hpp
index b2ec7a49f..cf86f585b 100644
--- a/qt_helpers.hpp
+++ b/qt_helpers.hpp
@@ -78,6 +78,12 @@ public:
   }
 };

+#if QT_VERSION < QT_VERSION_CHECK (5, 14, 0)
+// The Qt  devs "fixed" this  in 5.14 to  specialize to use  their own
+// qHash(), it doesn't  fix the problem we were  addressing as qHash()
+// returns a  uint so is  still a  poorly distributed 32-bit  value on
+// 64-bit platforms, but  we can't specialize ourselves  as Qt already
+// has - sigh.
 namespace std
 {
   // std::hash<> specialization for QString based on the dbj2
@@ -97,6 +103,7 @@ namespace std
     }
   };
 }
+#endif

 // Register some useful Qt types with QMetaType
 Q_DECLARE_METATYPE (QHostAddress);





locked Re: Mode Change in split operation

IU1JVO
 

Hi,
The rig is already directly connected to WSJT-X.
Is not a real problem, I need to set the VFO-B to the correct mode before. Then WSJT-X connected to the rig, set time by time the frequency needed.

Thanks.

73 de IU1JVO


locked Data Logging

Ed Bloom, KD9FRQ
 

I am using a DRAWS on a Pi as my computer.

I am seeing mobile stations move but I am not seeing the data in the View > Incoming Data > TNC Data Only screen.

Am I looking for it in the correct spot?

I am wanting to see what the general receive pattern is for the new antenna (it will get moved higher when the weather breaks) by only tracking the data I receive over the air.

Thanks,

Ed, KD9FRQ


locked Re: 2m using Flex-1500 and transverter.

Robin Moseley <robin@...>
 

Flex -1500 has  bad phase noise.. - don't amplify it..

http://sm5bsz.com/dynrange/dubus313.pdf

Robin G1MHU


locked Re: keying sequencer

AH0U
 

Agn, tnx... that is what I have been trying but there seems to be no way in WSJT to set up a PTT port to use to key the sequencer that is not the same port WSJT uses to key the rig.....no matter what port I use in WSJT using RTS/DTR it keys the rig and the sequencer sits there undisturbed... very frustrating :(


locked Re: Error in Sound Output: An Error open the audio outout device has occurred??

dk1wb
 

 

Hi Ed,

USB communication between PC and TRX is not reliable if the antenna is too close. QRP is certainly a solution but you may want to try this:
Connecting the shield of the Notebook-USB connector to station ground by means of a ground clip from a scope probe should allows you some QRO (see attached picture).

73 and GL,
Hans, DK1WB

 

Hello everyone,

Tnx for all the feedback. I tried the recommendations about turning the rf down
and that seems to have done the trick. At 20 watts the problem
is gone. I have some ferrite on the coax to my less than ideal antenna. My home
qth is Lansing MI and we are in an apartment, 3rd floor, 35 foot
balcony which is surrounded by rebar and cement. I am limited to a 20 dipole
which is very close to the rig. I don't recall having this problem at home
with a cushcraft r5 and g5rv antennas. The setup actually does pretty well on
with a clear shot at the ocean up the East coast and into Europe.