Date   

locked Simple unidirectional CAT protocol? #TechnicalHelpQuestion

David Lee
 

With the great help from this group, I've made progress building my FT8 transmitter. I've modified the WSJT-X source code to forward any messages to transmit out a USB serial port. It works well.

It occurs to me that I'd like to have WSJT-X provide a little more control over my home brew transmitter. CAT to the rescue!

Can you suggest a rig that uses a simple, unidirectional, ASCII protocol?

My point is that I'd rather not write the acknowledgement response code right now. I'd rather just receive plain text ASCII commands.

I'm sure I could review all the protocol specifications for every rig, but I thought someone might be aware of a simple one off the top of their head.

Would there be any problems just not sending a CAT response to WSJT-X?

Cheers,
David, N5TLZ


locked Re: #Elecraft K2 CAT Connection Fails #Elecraft

Joe Subich, W4TV
 

Make sure the shield of the PTT connector (1/4") in your
"Y" cable is connected to *PIN8* and the shield of the
mic connector (3.5mm) is connected to *PIN 7*. Some Heil
adapters get them reversed.

Also make sure the *ONLY* connections between the USB to
serial adapter and your KIO2 are pins 2, 3, and 5 (TxD,
RxD, ground).

73,

... Joe, W4TV

On 2022-03-13 11:36 AM, VA1CQ wrote:
Joe,
I used the Kenwood strapping on my Front Panel board in my K2.
Pin 1: AF
Pin 2: PTT
GND: 7&8.
No bias resistor is required for a Kenwood mic.
I never added any capacitor on the line from the PC audio to my mic input. But the SSB adapter schematic shows a 2.2 uF capacitor on the MIC AF input to the board routing into the Speech Compressor. I have Speech Compressor configured OFF and Mic Gain set at minimum in the K2 menu.
Murray VA1CQ


locked Re: Absolute frequency for symbol 0? #frequency #TechnicalHelpQuestion

Reino Talarmo
 

Hi David,
Have you noted that the frequency is changing slowly following a Gaussian sum curve from one symbol to the next? The amplitude stays constant from one symbol to the next one. Only amplitude smoothing is at the beginning and end of a transmission.
73, Reino OH3mA

-----Original Message-----
From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of David Lee
Sent: 13. maaliskuutata 2022 11:59
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Absolute frequency for symbol 0? #TechnicalHelpQuestion

Reino,
Thank you so much. I have considerable trouble reading that paper and I appreciate you finding the answer for me.

I modified wsjt-x to forward messages to transmit over a USB port to (another) Raspberry Pi. Here I calculate the tone sequence. I will then use this (along with the amplitude profile) to modulate a DDS. Very exciting project for me!

Cheers,
David, N5TLZ


locked Re: SSL/TLS support not installed error #install #windows11

Bill Seward
 

Having to download it every time it needs a refresh sort of defeats to concept of having it built into the software.

I suppose I'll just turn that feature off.


locked Re: Absolute frequency for symbol 0? #frequency #TechnicalHelpQuestion

David Lee
 

Thanks Andy!

I'm working on the code this AM.
David, N5TLZ


locked Re: Absolute frequency for symbol 0? #frequency #TechnicalHelpQuestion

Andy Talbot
 

1)
The RF generated is your upper sideband "dial frequency" plus the tone that
is stated as your Tx tone, That is the frequency for Tone-0

Andy
www.g4jnt.com


locked Re: #Elecraft K2 CAT Connection Fails #Elecraft

VE7RC
 

Joe,

I used the Kenwood strapping on my Front Panel board in my K2.
Pin 1: AF
Pin 2: PTT
GND: 7&8.

No bias resistor is required for a Kenwood mic.

I never added any capacitor on the line from the PC audio to my mic input. But the SSB adapter schematic shows a 2.2 uF capacitor on the MIC AF input to the board routing into the Speech Compressor. I have Speech Compressor configured OFF and Mic Gain set at minimum in the K2 menu.

Murray VA1CQ


--
This email has been checked for viruses by AVG.
https://www.avg.com


locked Re: SSL/TLS support not installed error #install #windows11

 

Got ya Hi Hi

On 3/13/2022 10:09 AM, Jim Shorney wrote:
But real hams DO!

73

-Jim
NU0C

On Sun, 13 Mar 2022 06:54:15 -0500
"Dave Tucker Nu4N" <dwtucker19@...> wrote:

You know what they say-Real men don't read directions Hi HI.

--
Tnx 73's de NU4N Dave
--
Thanks 73's de NU4N/Dave


locked Re: SSL/TLS support not installed error #install #windows11

Jim Shorney
 

But real hams DO!

73

-Jim
NU0C

On Sun, 13 Mar 2022 06:54:15 -0500
"Dave Tucker Nu4N" <dwtucker19@...> wrote:

You know what they say-Real men don't read directions Hi HI.


locked Re: External USB audio problem on Mac #macOS #txaudio

Michael Black
 

The IC756 does not adjust audio very well -- the audio to the computer is fixed for example.
You need an audio device where you can control the audio in/out level in analog space.
Like the SignaLinkFor the IC-756 you need the SLUSB8PD cable and SLMOD8PD jumper block.https://www.tigertronics.com/slusbmain.htm

I hooked up one of these to an IC-746PRO and it works just fine and is completely adjustable on the audio levels.
Mike W9MDB

On Sunday, March 13, 2022, 04:45:38 AM CDT, 6k2kus@... <6k2kus@...> wrote:

Hi,

I am using Mac and suffer from the following problem for every case.

Tested pc: iMac with Catalina and M1 air with Bir Sur
External USB audio: zoom H1n and xggcomms Digilink (using C-midia 0x0012)
Rig: Icom IC-756. Digilink uses FT232R USB UART.
WSJT-X: ver 2.5.4

The input (rx) volume is too high: I have to minimize the mic volume in the System Preferences. Then my rx level manages to go to 80dB.
The output (tx) volume is too low: I have raised the power lever to the highest and set the soundcard volume Max.
(By the way, if I try to raise the power lever up, it appears go down).
Therefore I cannot use the full power of my rig.

I think FLDigi seems to work fine with the same hardware and WSJT-X and JTDX with similar versions have the problem.

Thank you in advance.


locked Re: FTDX1200 locks up #Yaesu

Don, NN8B
 

Mike,

Thanks for the reply.
The WSJT/wsjtx/bin file does have libhamlib-4.dll.
I presume the file on sourceforge is the same.

This radio setup is at my county EMA and I will replace the
libhamlib-4.dll and test it Tuesday when I go into work.

73
Don, NN8B


locked Re: SSL/TLS support not installed error #install #windows11

 

Got it working this morning Bill. Sometimes it pays to read the directions !! You know what they say-Real men don't read directions Hi HI.

Tnx for the reply. Everything is fine now

73's Dave NU4N

On 3/13/2022 6:38 AM, Michael Black via groups.io wrote:
Hey Dave,I thought we fixed that problem for you.  At least I seem to remember not seeing the error anymore after installing the correct openssl package.
Mike W9MDB


On Sunday, March 13, 2022, 03:37:32 AM CDT, Dave Tucker Nu4N <dwtucker19@...> wrote:
I have the same problem when I fire up WSJT-x.

73's Dave NU4N

On 3/12/2022 11:04 PM, neil_zampella wrote:
Nothing to do with LoTW ... if all else fails, the User Guide does have
a link to download the file directly.

On 3/12/2022 8:13 PM, Bill Seward wrote:
I checked, all are 64 bit.

I wondered if it might be a LOTW issue, but it is still giving me the
error message tonight.

Bill






--
Tnx 73's de NU4N Dave
--
Thanks 73's de NU4N/Dave


locked Re: I can't understand what is the mede #TechnicalHelpQuestion

William Smith
 

More interested in _how_ you solved it than what it turned out to be, in case a similar question comes up again...

73, Willie N1JBJ

On Mar 13, 2022, at 4:46 AM, Pietro Molina <pietro@...> wrote:

Solved. If anyone is interested, it is KG-STV


locked Re: SSL/TLS support not installed error #install #windows11

Michael Black
 

Hey Dave,I thought we fixed that problem for you.  At least I seem to remember not seeing the error anymore after installing the correct openssl package.
Mike W9MDB

On Sunday, March 13, 2022, 03:37:32 AM CDT, Dave Tucker Nu4N <dwtucker19@...> wrote:

I have the same problem when I fire up WSJT-x.

73's Dave NU4N

On 3/12/2022 11:04 PM, neil_zampella wrote:
Nothing to do with LoTW ... if all else fails, the User Guide does have
a link to download the file directly.

On 3/12/2022 8:13 PM, Bill Seward wrote:
I checked, all are 64 bit.

I wondered if it might be a LOTW issue, but it is still giving me the
error message tonight.

Bill







--
Tnx 73's de NU4N Dave



--
Thanks 73's de NU4N/Dave


locked Re: Absolute frequency for symbol 0? #frequency #TechnicalHelpQuestion

David Lee
 

Reino,
Thank you so much. I have considerable trouble reading that paper and I appreciate you finding the answer for me.

I modified wsjt-x to forward messages to transmit over a USB port to (another) Raspberry Pi. Here I calculate the tone sequence. I will then use this (along with the amplitude profile) to modulate a DDS. Very exciting project for me!

Cheers,
David, N5TLZ


locked External USB audio problem on Mac #macOS #txaudio

6k2kus@...
 

Hi,

I am using Mac and suffer from the following problem for every case.

Tested pc: iMac with Catalina and M1 air with Bir Sur
External USB audio: zoom H1n and xggcomms Digilink (using C-midia 0x0012)
Rig: Icom IC-756. Digilink uses FT232R USB UART.
WSJT-X: ver 2.5.4

The input (rx) volume is too high: I have to minimize the mic volume in the System Preferences. Then my rx level manages to go to 80dB.
The output (tx) volume is too low: I have raised the power lever to the highest and set the soundcard volume Max.
(By the way, if I try to raise the power lever up, it appears go down).
Therefore I cannot use the full power of my rig.

I think FLDigi seems to work fine with the same hardware and WSJT-X and JTDX with similar versions have the problem.

Thank you in advance.


locked Re: I can't understand what is the mede #TechnicalHelpQuestion

Pietro Molina
 

Solved. If anyone is interested, it is KG-STV

Pietro i2OIM

On Tue, Mar 8, 2022 at 03:29 PM, Pietro Molina wrote:


Despite the help, I cant find out the mode.

Here a new screenshot with frequency scale:
https://1drv.ms/u/s!AuQm2UBQE7eKpa82VrgAMXsNXjj1tw?e=FnV2Gg

I'd tried 8PSK but I cant solve. Which SW is to be used for 16PSK or 16QAM?

May be it is digital voice mode?

Pietro I2OIM
On Tue, Mar 8, 2022 at 03:29 PM, Pietro Molina wrote:


Despite the help, I cant find out the mode.

Here a new screenshot with frequency scale:
https://1drv.ms/u/s!AuQm2UBQE7eKpa82VrgAMXsNXjj1tw?e=FnV2Gg

I'd tried 8PSK but I cant solve. Which SW is to be used for 16PSK or 16QAM?

May be it is digital voice mode?

Pietro I2OIM
On Tue, Mar 8, 2022 at 03:29 PM, Pietro Molina wrote:


Despite the help, I cant find out the mode.

Here a new screenshot with frequency scale: https://1drv.ms/u/s
!AuQm2UBQE7eKpa82VrgAMXsNXjj1tw?e=FnV2Gg

I'd tried 8PSK but I cant solve. Which SW is to be used for 16PSK or 16QAM?

May be it is digital voice mode?

Pietro I2OIM


locked Re: SSL/TLS support not installed error #install #windows11

 

I have the same problem when I fire up WSJT-x.

73's Dave NU4N

On 3/12/2022 11:04 PM, neil_zampella wrote:
Nothing to do with LoTW ... if all else fails, the User Guide does have
a link to download the file directly.

On 3/12/2022 8:13 PM, Bill Seward wrote:
I checked, all are 64 bit.

I wondered if it might be a LOTW issue, but it is still giving me the error message tonight.

Bill






--
Tnx 73's de NU4N Dave
--
Thanks 73's de NU4N/Dave


locked Re: Absolute frequency for symbol 0? #frequency #TechnicalHelpQuestion

Reino Talarmo
 

Hi David,

https://physics.princeton.edu/pulsar/k1jt/FT4_FT8_QEX.pdf seems to give a nice answer (1):
"The pulse amplitudes, bn, are integers in the range 0 – 7 for FT8 and 0 – 3 for FT4. With this convention the carrier frequency fc is the lowest tone frequency, i.e., the frequency transmitted during an interval with bn = 0."
That I took from 5. Generated Waveforms.

73; Reino OH3mA

What is the absolute frequency when transmitting symbol zero?
So. We have the carrier frequency, call it Fcarrier. (E.g., 10.136 MHz) Then, there's the audio transmission frequency, call it Faudio. (E.g., 1000 Hz) Also, there's the GFSK tone separation, call it Fgfsk. (6.25 Hz) When transmitting symbol 0, we produce Fzero.
So my question is: which of these expressions is correct for Fzero?
1) Fzero=Fcarrier+Faudio
or
2) Fzero=Fcarrier+Faudio+Fgfsk


locked Re: SSL/TLS support not installed error #install #windows11

neil_zampella
 

Nothing to do with LoTW ... if all else fails, the User Guide does have
a link to download the file directly.

On 3/12/2022 8:13 PM, Bill Seward wrote:
I checked, all are 64 bit.

I wondered if it might be a LOTW issue, but it is still giving me the error message tonight.

Bill



5621 - 5640 of 38043