Date   

locked Re: #txaudio #linux WSJT-X No TX audio issue #txaudio #linux

Steve K4RVA
 

Well, how about this for a coincidence.. I've been futzing around with this for the last two days, and not making any progress. Tonight I received several updates on Linux Mint, which included the kernel and 'alsa-ucm-conf'. I thought I would give it another try and - behold! WSJT-X is now sending audio!

FYI, I have the 'alsa_input...' and 'alsa_output..." audio devices selected in the configuration menu.

Cheers,
Steve K4RVA


locked Re: JT65 #decode

Jim Brown
 

On 9/9/2021 6:58 AM, Robert Woltag wrote:
 JT65 mode does not seem to decode anything.
Where are you looking for JT65? It's not a "random QSO" mode like FT8 and FT4, but more of a special purpose weak signal mode like MAP65, JT9, FST4 and Q65, and the newer of those modes, FST4 and Q65, are likely to replace JT65 and JT9.

73, Jim K9YC


locked Re: JT65 #decode

Lloyd Korb
 

Are you sure you have JT65B selected?

Lloyd  K8DIO

On Thu, Sep 9, 2021 at 5:22 PM Robert Woltag <rwoltag@...> wrote:
Hi, I am running WSJT-X v2.4.0.  FT8, FT4 etc seem to decode and transmit fine.  JT65 mode does not seem to decode anything.  Any suggestions?  Thanks Rob W1AFP



locked Re: Font too big #IssueReport

Chuck Freeman
 

Thanks Bill I will give it a shot!


locked Re: "Error in Sound Input" (message box) Circle w/ RED X ---- my WSJT is "BRICKED" #AudioIssues #Windows10 #Elecraft

Bill
 
Edited

RESOLVED: Microsoft  in   their quest for an infinitely configurable machine decided to allow users to mute the microphone on any and ail apps, those designed, and those yet to be designed like WSJT-X,  They grouped LINE IN as a MICROPHONE  under a single mute button.  So, if suddenly your green monitor bar quits showing signal, it could have been muted in the following settings: SYSTEM | PRIVACY | MICROPHONE


locked Re: "Error in Sound Input" (message box) Circle w/ RED X ---- my WSJT is "BRICKED" #AudioIssues #Windows10 #Elecraft

Bill
 

On Thu, Sep 9, 2021 at 02:11 AM, <bill333@...> wrote:
Microsoft in their quest for an infinitely configurable machine decided to allow users to mute the microphone on any and ail apps, those designed, and those yet to be designed like WSJT-X,  They groped LINE IN as a MICROPHONE  under a single mute button.  So, if suddenly your green monitor bar quits showing signal, it could have been muted in the following settings: SYSTEM | PRIVACY | MICROPHONE


locked Re: Font too big #IssueReport

Bill Somerville
 

On 09/09/2021 20:27, Chuck Freeman via groups.io wrote:
I installed Wsjtx on my laptop. I changed the font size in the settings menu but now the font is so big that I am not able to go back to the settings menu to change the font size and click on the OK button. The OK button is not visible. I tried thg o uninstall wsjtx and reinstalled the program but the font size stayed the same large size. Anyone have any ideas?

Hi Chuck,

the OK button should be the default button, hitting ENTER should accept the changes. Otherwise you can edit the WSJT-X.ini file and remove the lines starting:

Font=

and

DecodedTextFont=

73
Bill
G4WJS.


locked Font too big #IssueReport

Chuck Freeman
 

I installed Wsjtx on my laptop. I changed the font size in the settings menu but now the font is so big that I am not able to go back to the settings menu to change the font size and click on the OK button. The OK button is not visible. I tried thg o uninstall wsjtx and reinstalled the program but the font size stayed the same large size. Anyone have any ideas?


locked Re: #txaudio #linux WSJT-X No TX audio issue #txaudio #linux

Steve K4RVA
 

Sorry, I don't mean to hijack your thread, but I am having the same (or similar) issue.

I installed wsjtx_2.4.0_amd64.deb on a very fresh install of Linux Mint 20.2 Cinnamon on a laptop with integrated audio. Audio input and FT8 decoding works fine. CAT control (Kenwood TS-570D) and PTT via CAT are working.

But when I click either 'Tune' or 'Enable TX', the button will turn red but I do not get any audio out, and the 'wsjtx' process goes straight to 100% CPU utilization. At this point, the waterfall freezes, the audio input level meter goes blank (the green vertical bar disappears), and new decoded messages no longer appear in the Band Activity window. The interface stills responds, ie. I can open any menu items, click the Tune button, but the application is no longer functioning.

When I close WSJT-X (either by clicking the 'X' or via File->Exit), the application windows go away but the 'wsjtx' process is still running at 100% CPU. I can kill it easily with a Ctrl-C from the terminal where I started it, or with a SIGTERM from inside 'top'.

I tried installing it on a different PC, also with Linux Mint 20.2, also with integrated/on-board audio and I got the exact same results.
I tried selecting several of the various audio output devices on both PCs (default, jack, oss, pulse, front, and several others with long cryptic names) and I got the same results.
I looked through ~/.local/share/WSJT-X/*.log and /var/log/syslog, but nothing was immediately apparent. Not exactly sure what to look for, though.
Fldigi outputs audio on both PCs.
It looks like pulseaudio is the audio server being used, but I don't know which other ones to look for in case there is a conflict or something.

Does anyone have any suggestion on where to look next? Is anyone else running 2.4.0 on Linux Mint (or another Ubuntu/Debian variety) successfully?

Cheers,
Steve K4RVA


locked Re: AO-100 Sat #IssueReport #FT8

Carlos
 

Hi to all,

Fortunately is this not my signal, but I heard this wave issue today and also sometimes ago on the satellite AO-100 in the mode FT8.

It sounds like RTTY. I enclose the wav file.

Some weeks ago I also asked for this strange issue, but didn't get any answer yet

Please give me any ideas.

Thanks a lot , Karl OE3JAG
My rig is: raspberry, buster; wsjtx 2.4.0, FT847, DXpatrol Up- and Down-converter, 1m dish


Robert Woltag
 

Hi, I am running WSJT-X v2.4.0.  FT8, FT4 etc seem to decode and transmit fine.  JT65 mode does not seem to decode anything.  Any suggestions?  Thanks Rob W1AFP


locked Re: WSJT-X shuts down unexpectedly (Raspberry Pi Raspian OS) #wsjt-x-crashing

Heikki Pisilä
 

i think you could start from this v2.3.0 installation works 100% when you follow the instructions.

https://photobyte.org/raspberry-pi-update-to-wsjt-x-2-3-0/

73

Heikki/oh8gkp



Bill Somerville9.9.2021 klo 20:14:

On 09/09/2021 18:00, S Johnson wrote:
Is there a bug repository where I can file this for (hamlib/wsjtx) developers? I can also offer to test any potential code fix on my Pi to help develop a solution.

OM,

have you tried the WSJT-X v2.5.0 RC6 release?

73
Bill
G4WJS.





locked Re: WSJT-X shuts down unexpectedly (Raspberry Pi Raspian OS) #wsjt-x-crashing

Bill Somerville
 

On 09/09/2021 18:00, S Johnson wrote:
Is there a bug repository where I can file this for (hamlib/wsjtx) developers? I can also offer to test any potential code fix on my Pi to help develop a solution.
OM,

have you tried the WSJT-X v2.5.0 RC6 release?

73
Bill
G4WJS.


locked Re: WSJT-X shuts down unexpectedly (Raspberry Pi Raspian OS) #wsjt-x-crashing

S Johnson
 

Is there a bug repository where I can file this for (hamlib/wsjtx) developers? I can also offer to test any potential code fix on my Pi to help develop a solution. 


locked Re: "Error in Sound Input" (message box) Circle w/ RED X ---- my WSJT is "BRICKED" #AudioIssues #Windows10 #Elecraft

Bill
 
Edited

THE FIX IS IN !!!    Microsoft in their quest for an infinitely configurable machine decided to allow users to mute the microphone on any and ail apps, those designed, and those yet to be designed like WSJT-X,  They groped LINE IN as a MICROPHONE  under a single mute button.  So, if suddenly your green monitor bar quits showing signal, it could have been muted in the following settings: SYSTEM | PRIVACY | MICROPHONE


locked Re: FT8 via running satellite #macOS #FT8

Carlos
 

TU, Dave,
I guess my gpredict is not able to update the doppler tuning so fast.
I will try some other Software.
And try to read your mentioned article.
73, Karl OE3JAG
Am 09.09.21, 00:09 schrieb "W0DHB via groups.io" <w0dhb@...>:

Karl

A group of us here in the U.S. have had great success using FT4.
It does require that you set your tracking software to update Doppler tuning at greater than 2 times per second .
SatPC32 and FlexSATPC software and I'm certain others can be set up to do this.

There was an article in the Amsat North America Journal Summer 2020 about satellite FT4 operations.

73's Dave W0DHB 


locked Anyone using a SunSDR2 Pro #Cat_RigControl #macOS

Randy Diddel
 

Good day,

I just got a new to me SunSDR2 Pro. Running ExpertSDR2 on a Mac.I have the sound side sorted just fine-getting decodes on all bands. I have TCI enabled in the Options on port 40001.

On the WSJT-X side, I am using DX Lab Suite Commander pointing to 127.0.0.1:40001 Pressing the Test CAT button and it never turns red or green. I have tried the actual IP of the computer in lieu of the loopback address.

Please see attached screen shots of what I am getting.



--
Randy Diddel
K5RHD
DM79ku
Arvada, CO


locked Re: FT8 via running satellite #macOS #FT8

W0DHB
 

Karl

A group of us here in the U.S. have had great success using FT4.
It does require that you set your tracking software to update Doppler tuning at greater than 2 times per second .
SatPC32 and FlexSATPC software and I'm certain others can be set up to do this.

There was an article in the Amsat North America Journal Summer 2020 about satellite FT4 operations.

73's Dave W0DHB 


locked Re: Full duplex mode for Satellite operations #EnhancementReqest

W0DHB
 

Thanks for your response Bill.

I agree that development effort of that magnitude would not be justified, especially when running a second instance of WSJT-X is quite sufficient.

Dave W0DHB


locked Re: #IssueReport #WSPR #IssueReport #WSPR

Hasan Schiers N0AN
 

Also RC6 here, although downloaded a few days ago. I think there was a hamlib fix since then, but have not downloaded since very early RC6.

73, N0AN
Hasan


On Wed, Sep 8, 2021 at 11:21 AM Bill Somerville <g4wjs@...> wrote:
Hi Hasan,

Steve, K9AN, and I are running WSPR band-hopping with a variety of bands set for Tune and Rx only. Neither of us are seeing this issue so far. I am using the latest 2.5.0 RC6 version.

73
Bill
G4WJS.

On 08/09/2021 15:00, Hasan Schiers N0AN wrote:
No, no errors at all, see an occasional audio stream error, nothing else

Hasan


On Wed, Sep 8, 2021 at 8:20 AM Bill Somerville <g4wjs@...> wrote:
Hi Hasan,

are there any Hamlib error messages in the WJST-X wsjtx_syslog.log file that correlate with the time of the issue?

73
Bill
G4WJS.

On 08/09/2021 01:09, Hasan Schiers N0AN wrote:
Bill,
I found the correlation I was looking for. 

If I tell WSPR Schedule to use the TUNE function (to make the autotuner adjust the antenna SWR on each band prior to transmitting), the ENABLE Tx light goes out in short order (next transmission or so).

If I uncheck the boxes on each band for Tune, and let the transmit signal itself actuate the auto-tuner, everything works normally.  

In reality, the TUNE function in the Scheduler is redundant, because the autotuner itself will auto-tune when RF is sent to it anyway, there is no need to 'pre-tune' things.

However, what I am reporting is undesirable and probably should be fixed, if it's a real malfunction.

73, N0AN
Hasan


On Sat, Sep 4, 2021 at 12:21 PM Bill Somerville <g4wjs@...> wrote:
On 04/09/2021 13:34, Hasan Schiers N0AN wrote:
WSJT-X 2.5.0 RC5
Mode WSPR
 
Issue:
 
When in Band Hopping Mode, with a proper schedule, the Enable Transmit button randomly goes dark and never lights up again.
 
This results in hours and hours of listening overnight with no transmitting. 
 
Is there an order effect or something that would cause this in terms of setup? It used to work perfectly with identical settings many versions ago.
 
Anyone else seen this?
 
TIA, 73, N0AN
Hasan

Hi Hasan,

that behaviour may be caused by a CAT error. Have a look in the wsjtx_syslog.log file (in the WSJT-X log files directory) for any Hamlib error messages around the time that the "Enable Tx" button resets.

73
Bill
G4WJS.





9581 - 9600 of 37955