Date   

locked Re: wsjt-x v2.4.0 hamlib problem #Cat_RigControl

Dana Shtun
 

I just upgrades as well, macOS and the program decodes froze after a couple of hours….
No debug messages or alerts….also frequency was not correct.?? 

DS

On May 24, 2021, at 13:25, Walter Egenmaier <wegenmaier@...> wrote:

Same error I'm getting with ver 2.2 and 2.3.1...so I think I have some settings wrong and will try to reset those and see if I get the same error. I'm listening to responses to this to see if it fixes my problem as well. I'm a first time user of WSJTX, so likely settings on my radio or software not quite right yet. I'm using FT-991A, Win 10, VSPE (virtual com port software to give me a com7). 

On Mon, May 24, 2021 at 12:21 PM geoff wiggins via groups.io <g4xmj=btinternet.com@groups.io> wrote:
I have just upgraded to v 2.4.0 and have started to experience a hamlib 
error, see attached pic. This didn't happen with v 2.3.0. After clicking 
ok a couple of times the issue goes away. It comes back after about 30 
mins or so later.

Win 10, flex 5000, powersdr, mode data\pkt, split operation rig.

Ideas?

73 Geoff.






-- 
Walter H. Egenmaier, O.D
EyeCare Consultants
Evansville, IN 47708
(812) 426-2020 Phone
(812) 426-2828 Fax



locked #general WSJT-X 2.4.0 User Guide: Where to send translations? Proposals for corrections #general

Frode Igland
 

Thanks to the Development Team for WSJT-X 2.4.0.

Where to send translations?

I have downloaded and tried WSJT-X 2.4.0 as well as the User Guide. I have also reviewed the WSJT-X 2.4.0 User Guide for translation and have completed the Norwegian translation. Having submitted a number of translations for v2.3 (GAs and release candidates), in accordance with the User Guide section 1.4, without seeing them published, I wonder where to send them for publication?

I don’t know if translations for other languages have not been forthcoming, or if they just haven’t been published, but apparently, translations for several languages have been lagging behind the version numbers.


Proposals for corrections in WSJT-X 2.4.0. User Guide

During my review I have come across a few issues that needs the attention of the editor of the User Guide. Some of these issues have been reported for the user guides for v2.3v2.4.0-release candidates, but apparently they have survived into the GA version, as well.


Section 3.1

The links for Win32 OpenSSL Light Package and Win64 OpenSSL Light Package are incorrect. They link to version 1_1_1j: https://slproweb.com/download/Win32OpenSSL_Light-1_1_1j.msi  and https://slproweb.com/download/Win64OpenSSL_Light-1_1_1j.msi


Version 1_1_1j is no longer available on the linked page.


The latest versions are 1_1_1k, and the correct links are https://slproweb.com/download/Win32OpenSSL_Light-1_1_1k.msi  and https://slproweb.com/download/Win64OpenSSL_Light-1_1_1k.msi

 

Section 10.1.4 Mode menu

The mode menu shown in the User Manual is the mode menu from v2.3, containing the now deprecated modes QRA64 and ISCAT.

In v2.4.0 theses two modes have been replaced by Q65.

The mode menu illustration needs updating.

 

Section 10.1.9 Help menu

The previous section 10.2 Button Row has lost its numbering and the previous section title has now been replaced by:

    === Button Row

// Status=edited

 

The Button Row obviously has no place under Section 10.1.9 Help menu, and should have its number 10.2 reissued, requiring a renumbering of the current sections 10.2 – 10.9 to 10.3 – 10.10.

 

Section 14. Cooperating programs

JTAlert has been updated to version 2.50.1, with a considerable layout makeover from v2.14.


It may be worthwhile to update the illustration.

 

Section 16. Frequently Asked Questions

Question #7.  

I am using WSJT-X with Ham Radio Deluxe. All seems well until I start HRD Logbook or DM780 running in parallel; then CAT control becomes unreliable.

You may see delays up to 20 seconds or so in frequency changes or other radio commands, due to a bug in HRD. HRD folks are aware of the problem, and are working to resolve it.

I am a Ham Radio Deluxe user myself, having never experienced any massive delays, nor have I noticed any attention on this issue in the various user forums. Consequently, I have contacted HRD Support regarding this information. According to HRD Support the delays have nothing to do with the HRD software, nor WSJT-X, and HRD are not working to solve this issue. If this had been a problem, HRD Support would have had a large number of support requests on this matter, and they don’t. The problem is caused by operators trying to run a number of softwares on computers with insufficient processing power.

According to HRD Support the information in the preceding paragraph has been conveyed to the WSJT-X Development team on a number of occasions, aiming to correct the information in the User Guide, but it has been impossible to have this corrected, so they have just given up. I promised them to make another attempt.

Having spent considerable time translating the User Guide over the last several years, as well as having made proposals for corrections (which have been corrected), it is my firm belief and opinion that the WSJT-X User Guide shall be accurate, reliable and up to date, like it is on the workings of WSJT-X, and not convey incorrect information about other softwares or other software suppliers.

Isn’t it time to correct this error, and delete this FAQ?

 

Section 17.2.10 Summary

Table 7

Mode

FEC Type

(n,k)

Q

Modulation type

Keying rate (Baud)

Bandwidth (Hz)

Sync Energy

Tx Duration (s)

S/N Threshold (dB)

FST4-15

LDPC

(240,101)

4

4-GFSK

16.67

67.7

0.25

9.6

-20.7

 

Assuming that Bandwidth equals (Keying Rate) × (number of tones/frequencies in the Modulation Type), like it is for the other FST modes, I guess the Bandwidth should amount to 16.67 × 4 = 66.7 Hz, not 67.7 Hz, or is there something special about the bandwidth for the FST4-15 mode?

73, Frode LA6VQ


locked Re: Receive only decoder #general

Mike
 

Appreciate the suggestions  but I take my phone to shack and I have qrm so thats out of the window. And the idea of purchasing https://www.keysight.com/us/en/software/application-sw/spectrum-monitoring-software/signal-surveyor-4d.html#/ at $27000 is more than the last 2 new vehicles Ive bought.

I was looking for VHF only software decoders but including some of the ones removed from WSJT-X (and still included in the likes of MSHV JT6M and FSK441) But selectable on one screen and then that be able to start the full time TX/RX software by choice. Otherwise just being able to monitor and see whats on the band. ie MS EME or just normal tropo and really I can find that out myself on PSK reporter and find it is unaccompanied FT8. I realize, like WSPR its shows that there is an opening between A and B but i have a good set of ears and I hear the data chatter before its decoded on screen and the likes of JT6M and JT4G I hear immediately. 

But Im detracting from my original thought - SDR direct into decent 4 Core I7 decodeing at least 10khz wide or even wider if the rx allows it. Please just lead me in the right direction
--
Mike
GD6ICR Peel Isle of Man


locked Prior Release Notes? #general

Larry Banks
 

Where can I find Release Notes for versions prior to 2.4? They are not at the end of the 2.4.0 notes.

73 -- Larry -- W1DYJ


locked Re: wsjt-x v2.4.0 hamlib problem #Cat_RigControl

Walter Egenmaier <wegenmaier@...>
 

Same error I'm getting with ver 2.2 and 2.3.1...so I think I have some settings wrong and will try to reset those and see if I get the same error. I'm listening to responses to this to see if it fixes my problem as well. I'm a first time user of WSJTX, so likely settings on my radio or software not quite right yet. I'm using FT-991A, Win 10, VSPE (virtual com port software to give me a com7). 

On Mon, May 24, 2021 at 12:21 PM geoff wiggins via groups.io <g4xmj=btinternet.com@groups.io> wrote:
I have just upgraded to v 2.4.0 and have started to experience a hamlib
error, see attached pic. This didn't happen with v 2.3.0. After clicking
ok a couple of times the issue goes away. It comes back after about 30
mins or so later.

Win 10, flex 5000, powersdr, mode data\pkt, split operation rig.

Ideas?

73 Geoff.






--
Walter H. Egenmaier, O.D
EyeCare Consultants
Evansville, IN 47708
(812) 426-2020 Phone
(812) 426-2828 Fax


locked Re: Split Operation with Rig Mode #IssueReport

Miloš Soukup
 

Hi all,

It seems the problem is gone after update to 2.4.0.

73! de Miloš, OK1FMY


Hi Mark,

I can confirm it. I use FT-817 also and version 2.3.1. I control my FT-817 directly from WSJT-X without any intermediate app. I found Split "Fake It" does not work (it was already reported) and
I tried to switch to "Rig". Regardless the band VFOa is switched to, VFOb stays on 7 MHz. CAT test passes OK and the circle around S is in green. So, I guess there is a bug related to Split in 2.3.1.

73, Miloš OK1FMY



locked wsjt-x v2.4.0 hamlib problem #Cat_RigControl

geoff wiggins
 

I have just upgraded to v 2.4.0 and have started to experience a hamlib error, see attached pic. This didn't happen with v 2.3.0. After clicking ok a couple of times the issue goes away. It comes back after about 30 mins or so later.

Win 10, flex 5000, powersdr, mode data\pkt, split operation rig.

Ideas?

73 Geoff.


locked Re: Help needed #GeneralGroupInfo

Jim Bacher - WB8VSU
 

Dave, that question has been answered many times on this list. Your PCs time is inaccurate. Go to https://time.is and check your time. Afterwards install a ntp program as the wsjt-x install instructions said to do.

Jim Bacher, WB8VSU
wb8vsu@...

On May 24, 2021, at 10:49 AM, Dave Tucker Nu4N <dwtucker19@...> wrote:
I have made a couple of posts yesterday about WSJTX not decoding. Is there anyone out there of the 2000 plus members could give me a hand?
Surely someone has some idea about how to fix my problem.


locked Re: Intl. WSPR Beacon Project #Beacons

Roland
 

Quick update on the Intl. WSPR Beacon Project, currently we have 15 candidates from 8 DXCC entities expressing their interest to run a Beacon. Still missing Japan. Please help to spread the word. Thanks.

73
Roland


locked Re: Disable TX After 73

 

I was about to report it as a bug, but decided to do a quick search. OK understand, and I do re-enable TX most times after I send RR73, especially as that also resends RR73 if your QSO partner repeats the Rxx message. I's just I sometimes forget and then it's a nuisance.

Maybe the settings button for this should be disabled if "Call 1st" is set.
--
73 Phil GM3ZZA


locked #Beacons Q65 generated by direct upconversion #Beacons

Andy Talbot
 

16F1827 PIC generating Q65B-15  from a pre-stored set of symbols via I/Q upconverter at 3.4GHz. 

Two pulse width modulators on the chip generate  0° and 90° sines from a numerically controlled oscillator sampled at 31250Hz, frequency determined by the symbol set read out at the symbol period.

Tones are upconverted in an ADL5375 quad upconverter chip direct from baseband to RF - the chip works over the frequency range 400 - 6000MHz

As the NCO generates an I/Q output, it is perfectly in order to programme negative frequencies; here the 854Hz frequency span is covered by generating tones from -433Hz to +420Hz.

The unchanging carrier at the centre of the screen at about -20dBc is carrier leakage.   NO attempt was made to null this out any more.    The nice thing about baseband upconversion is that leakage and image response fall on top of the wanted signal, so provided they are 17dB down or more, go unnoticed by any demodulator.


locked Re: Microphone Icon on Win10 #FT8

neil_zampella
 

This has nothing to do with such an activity.   This is a new 'feature' of windows so that the user knows that a device is using their mic input.   Has more to do with privacy concerns than anything else.

Neil, KN3ILZ

On 5/24/2021 11:21 AM, Jim Bacher - WB8VSU wrote:
George, I wonder if you have wsjt-x listen to your radio speaker by microphone. Make sure you have it configured to use the correct audio in.

A quick test is turn off the speaker on your radio and see if it stops decoding.

I accidentally had wsjt-x using the microphone with the speaker turned on and it had no issue running that way.

Jim Bacher, WB8VSU
On May 24, 2021, at 10:48 AM, George Weller <gvweller@...> wrote:
Old laptop died.  Loaded everything on the new one ('waaay faster!) and everything works (after some effort).  But one thing, I haven't seen before.  In the Win10 tray, a microphone icon.  Mouse over, and it says "WSJT-X is using your microphone".  And the icon goes away on Xmit, comes back on Rcv.  It seems to have no bad effect, as PSKreporter shows my signal decoded all over the place.  Haven't seen this on other apps.  Maybe it's just a twist from the latest build of Windows.  Anyone else seen this?






locked Re: Calling with TX2 #FT8

K0GU
 

> The software
> was designed such that CQ'ing Stations call using TX6 and answering Stations
>  respond with TX1, including their Grid.

The software was also designed so that one can disable Tx1.

Come join us on 6m where the extra 15 seconds can mean a DX QSO or not. Virtually no DXer on 6m uses Tx1. For domestic I always send Tx1 but not DX.
--
73,  Jay  K0GU  DN70mq


locked Re: Microphone Icon on Win10 #FT8

Jim Bacher - WB8VSU
 

George, I wonder if you have wsjt-x listen to your radio speaker by microphone. Make sure you have it configured to use the correct audio in.

A quick test is turn off the speaker on your radio and see if it stops decoding.

I accidentally had wsjt-x using the microphone with the speaker turned on and it had no issue running that way.

Jim Bacher, WB8VSU
wb8vsu@...

On May 24, 2021, at 10:48 AM, George Weller <gvweller@...> wrote:
Old laptop died.  Loaded everything on the new one ('waaay faster!) and everything works (after some effort).  But one thing, I haven't seen before.  In the Win10 tray, a microphone icon.  Mouse over, and it says "WSJT-X is using your microphone".  And the icon goes away on Xmit, comes back on Rcv.  It seems to have no bad effect, as PSKreporter shows my signal decoded all over the place.  Haven't seen this on other apps.  Maybe it's just a twist from the latest build of Windows.  Anyone else seen this?




locked Re: Microphone Icon on Win10 #FT8

Bill Somerville
 

On 24/05/2021 02:28, George Weller wrote:
Old laptop died.  Loaded everything on the new one ('waaay faster!) and everything works (after some effort).  But one thing, I haven't seen before.  In the Win10 tray, a microphone icon.  Mouse over, and it says "WSJT-X is using your microphone".  And the icon goes away on Xmit, comes back on Rcv.  It seems to have no bad effect, as PSKreporter shows my signal decoded all over the place. Haven't seen this on other apps.  Maybe it's just a twist from the latest build of Windows.  Anyone else seen this?
Hi George,

it is a Windows 10 security feature, it should ready say "WSJT-X is using one of your recording devices". Just a reminder that an application is making a recording of something.

73
Bill
G4WJS.


 

I have made a couple of posts yesterday about WSJTX not decoding. Is there anyone out there of the 2000 plus members could give me a hand?
Surely someone has some idea about how to fix my problem.

--
Thanks 73's de NU4N/Dave


locked VS: [WSJTX] #GeneralGroupInfo SLOW TO DECODE. #GeneralGroupInfo

Reino Talarmo
 

As I stated earlier wsjt-x is slow to decode. Like double decoding.
Appreciate the help
--
Thanks 73's de NU4N/Dave

 

Hi Dave,

Now I think I got you double decoding issue. WSJT-X performs now decoding in three steps in development of v2.2.0-rc1:

  FT8: Decoding is now spread over three intervals.  The first

      starts at t = 11.8 s into an Rx sequence and typically yields

      around 85% of the possible decodes for the sequence.  You

      therefore see most decodes much earlier than before.  A second

      processing step starts at 13.5 s, and the final one at 14.7 s.

      Overall decoding yield on crowded bands is improved by 10% or

      more.  (Systems with receive latency greater than 0.2 s will see

      smaller improvements, but will still see many decodes earlier

      than before.)

Results of those decodes are presented as soon as possible meaning three flashes of the Decode button. In a slow computer he last ones may take decoding to the  next transmission timeslot. Selecting Decode level Fast or Normal may help.

Good Hunting!

73, Reino OH3mA

 

 

 

 


locked Re: #GeneralGroupInfo Problem Decoding. #GeneralGroupInfo

Jim Brown
 

On 5/23/2021 8:25 AM, Dave Tucker Nu4N wrote:
Any thoughts ??
Yes. Always read the release notes when upgrading software. Your question was anticipated by the developers, who wrote Release Notes and Quick Start guides, and detailed help docs HOPING that users would read them.

73, Jim K9YC


locked Re: Rig Failure #Cat_RigControl

Ed Hennigan
 
Edited

Walt,
 
Make sure you install NET 5 Runtime if you have not already done so.
Nest, in AC Log, Settings>Rig Interface>Select Rig.....should be None.
Now you need to close AC Log.
Start WSJT first and you should now see the frequency your rig is set to in the small window within WSJT.
On WSJT go to File>Setting. Radio Tab....should look like the third screen shot
then go to the reporting tab....should look like the fourth screen shot.
 
I have an FTdx 1200 and had the same issues you are having until I finally got it figured out 3 days ago
after much frustration. I also use JTalert to communicate with AC Log and make the log entries
 
Hope this helps out.
 
Ed
K7EPH
 


From: main@WSJTX.groups.io <main@WSJTX.groups.io> on behalf of Walter Egenmaier <wegenmaier@...>
Sent: Sunday, May 23, 2021 1:52 PM
To: main@WSJTX.groups.io <main@WSJTX.groups.io>
Subject: [WSJTX] Rig Failure #Cat_RigControl
 
I am trying WSJTX 2.3.1 for the first time with latest N3FJP  (ACL ver 7.01), WIN 10, 64 bit laptop, and FT-991A (with internal modem).
I have never used WSJTX software before, but do use N3FJP and since it is compatible, I though I would try to set this up on my rig for FT8.
As you can see by the attachment, I have several rig failures. Any suggestions on how to fix. I am set up on COM7 using VSPE (Virtual Serial Port Emulator software) which does work with my ACL from N3FJP. The ACL software has rig control and it reads the freq on my rig perfectly. So not sure what my next step should be. 
I did get band activity that wasn't there before, so not sure how that happened. I'm on USB 7.074 MHz.
Appreciate any help to get me started. 
Walt / WB4ZUT
73s


locked Microphone Icon on Win10 #FT8

George Weller
 

Old laptop died.  Loaded everything on the new one ('waaay faster!) and everything works (after some effort).  But one thing, I haven't seen before.  In the Win10 tray, a microphone icon.  Mouse over, and it says "WSJT-X is using your microphone".  And the icon goes away on Xmit, comes back on Rcv.  It seems to have no bad effect, as PSKreporter shows my signal decoded all over the place.  Haven't seen this on other apps.  Maybe it's just a twist from the latest build of Windows.  Anyone else seen this?

11981 - 12000 of 36960