Date   

locked Re: Two program releases: WSJT-X 2.3.1 (GA) and WSJT-X 2.4.0-rc4 #Q65

Les Listwa
 

Hi Joe and team,

Just want to  report a successful, quick and easy 1296 EME Q65-30 contact with a report of -27 db. Nice to see a real time signal report.   And just want to mention the auto doppler correction is pure magic, making 1296 mhz contacts so much easier. 

73
Les
W2LPL


locked Re: Ubuntu 20.04 & wsjtx2.3.0 ALSA audio HW:x,y challenges #AudioIssues #linux

Bill Somerville
 

On 27/03/2021 11:04, mike.j.kasper@... wrote:
I've spent WAY to much time trying to get WSJTX to share the audio input.  The primary goal is to get FLDIGI & WSJTX to share an input for decoding, but utilizing the DSNOOP option or trying to directly access the HW audio results in: "Error in Sound Input Requested input audio format is not supported on device".  Only using PLUGHW: "works"

I found that I have a USB microphone that does work with the DSNOOP, but both my radio USB audio card and the internal audio card refuse.  Strange thing is, the USB microphone (snowball) ONLY support S16_LE, while the other cards support other formats.

Audio card details:

Card 0, ID `Digital', name `Shure Digital'
  Device 0, ID `USB Audio', name `USB Audio', 1 subdevices (1 available)
    1..2 channels, sampling rate 8000..48000 Hz
    Sample formats: S8, S16_LE
      Subdevice 0, name `subdevice #0'
Card 1, ID `Snowball', name `Blue Snowball'
  Device 0, ID `USB Audio', name `USB Audio', 1 subdevices (1 available)
    1 channel, sampling rate 8000..48000 Hz
    Sample formats: S16_LE
      Subdevice 0, name `subdevice #0'
Card 2, ID `PCH', name `HDA Intel PCH'
  Device 0, ID `ALC231 Analog', name `ALC231 Analog', 1 subdevices (1 available)
    2 channels, sampling rate 44100..192000 Hz
    Sample formats: S16_LE, S32_LE
      Subdevice 0, name `subdevice #0'

Any pointers on what format wsjtx is asking for and/or why these cards refuse direct hardware (aka requiring PLUGHW)???
OM,

WSJT-X requests 48,000 Hz 16-bit little endian, but pulseaudio will do the necessary conversion if that is not available in the hardware. Some users have reported that changing the duplex settings of some sound cards is necessary.

73
Bill
G4WJS.


locked Re: #FT8 #FT8

Bill Somerville
 

On 27/03/2021 13:35, Jerry Lofstead wrote:
I can no longer find the menu on/off option in the .ini file.  what happened to it.  I want to see the menu bar.
Jerry W3CDE
Jerry,

what's wrong with checking/unchecking the "Menus" box to the right of the central row of buttons?

73
Bill
G4WJS.


locked Re: Two program releases: WSJT-X 2.3.1 (GA) and WSJT-X 2.4.0-rc4 #Q65

Bill Somerville
 

On 27/03/2021 13:55, w5ec wrote:
I have been using wsjtx xv2.1.2 from way back and are perfectly happy with it. I now want to go to v2.4.0 for all the improvements. What is best way to upgrade?
I want to be able to go back to v2.1.2 if bugs cause me problems. I don't want it to affect my settings. At my age I don't want any more problems!
Bill W5EC
Hi Bill,

unless you are interested in exploring the new Q65 mode I would recommend upgrading to v2.3.1 rather than the v2.4.0 release candidates.

73
Bill
G4WJS.


locked Re: Two program releases: WSJT-X 2.3.1 (GA) and WSJT-X 2.4.0-rc4 #Q65

w5ec
 

I have been using wsjtx xv2.1.2 from way back and are perfectly happy with it. I now want to go to v2.4.0 for all the improvements. What is best way to upgrade?
I want to be able to go back to v2.1.2 if bugs cause me problems. I don't want it to affect my settings. At my age I don't want any more problems!
Bill W5EC


locked #FT8 #FT8

Jerry Lofstead W3CDE
 

I can no longer find the menu on/off option in the .ini file.  what happened to it.  I want to see the menu bar.
Jerry W3CDE


locked 10m Q65/30A Testing 27Mar21 28.135MHz #Q65

Bob K4RCG
 

As known, Q65 was not developed for 10m, but remains an interesting possibility.  Testing today 28.135 MHz if anyone is around.

73 de Bob
K4RCG


locked Ubuntu 20.04 & wsjtx2.3.0 ALSA audio HW:x,y challenges #AudioIssues #linux

mike.j.kasper@...
 

I've spent WAY to much time trying to get WSJTX to share the audio input.  The primary goal is to get FLDIGI & WSJTX to share an input for decoding, but utilizing the DSNOOP option or trying to directly access the HW audio results in: "Error in Sound Input Requested input audio format is not supported on device".  Only using PLUGHW: "works"

I found that I have a USB microphone that does work with the DSNOOP, but both my radio USB audio card and the internal audio card refuse.  Strange thing is, the USB microphone (snowball) ONLY support S16_LE, while the other cards support other formats.

Audio card details:

Card 0, ID `Digital', name `Shure Digital'
  Device 0, ID `USB Audio', name `USB Audio', 1 subdevices (1 available)
    1..2 channels, sampling rate 8000..48000 Hz
    Sample formats: S8, S16_LE
      Subdevice 0, name `subdevice #0'
Card 1, ID `Snowball', name `Blue Snowball'
  Device 0, ID `USB Audio', name `USB Audio', 1 subdevices (1 available)
    1 channel, sampling rate 8000..48000 Hz
    Sample formats: S16_LE
      Subdevice 0, name `subdevice #0'
Card 2, ID `PCH', name `HDA Intel PCH'
  Device 0, ID `ALC231 Analog', name `ALC231 Analog', 1 subdevices (1 available)
    2 channels, sampling rate 44100..192000 Hz
    Sample formats: S16_LE, S32_LE
      Subdevice 0, name `subdevice #0'

Any pointers on what format wsjtx is asking for and/or why these cards refuse direct hardware (aka requiring PLUGHW)???


locked Re: program release WSJT-X 2.4.0-rc4 #linux #IssueReport #MSK144

Carlos
 

Hi to all,
Thanks für the new two program versions.
On 2.4.0-rc4 I found out that in MSK144 the call is not copied to the standard messages wehen doubleclick on a CQ call.
You have to double click the CQ call line in the Band Activity window.
then Generate Std Msgs
and the Enable TX.
In my opinion I found it useful to take over the call in the Std Msgs.
73, TU, Karl OE3JAG


locked Re: Two program releases: WSJT-X 2.3.1 (GA) and WSJT-X 2.4.0-rc4 #Q65

 

Hi friends
Thanks Joe and team for your work.
Installed the -rc4 Version of WSJT-X 2.4.0 without problems. It was too late for checking on 6m - nobody there and moon already too high - but I made a fine Q65_60A QSO (terrestrial) over 700 km. Nothing visible in the waterfall, but in the spectrum it was. Will try EME receiving on 2m and 6m today.
I came to having some minor "wishes" to the program concerning mainly the user interface and setup procedure. But this is secondary and I will address the items to the developpers directly.
73 de Christoph DF9CY
---

Christoph Petermann DF9CY

JO54al (Baltic Sea Coast)
7 MHz Dipole @9,5m - 400w

50MHz 6 ele OP-DES Yagi - 270w

144MHz 9 ele DK7ZB - 330w
432MHz 23 ele - 35w

https://www.df9cy.de


locked #FST4W WSPRNET Reporting #FST4W

Andy Talbot
 

I've been sending a FST4W-900 signal for the last hour or so and monitoring WSPRNET for reports

Some stations report the mode correctly as '15'.   Others as '2'
Is this caused in WSJT-X, or is it something at the the WSPRNET end ?


locked Re: WSJT-X using Mac OS Catalina

wwindham@...
 
Edited

I have MacBook Pro (16-inch, 2019) and I am running Catalina 10.15.7.  I am missing something when it comes to installing the Silicon Labs VCP Driver.  I get down to the Guidance step, and select Open Security Preferences, but then I can't find anything anywhere in the security preferences that shows the message they show to look for ("System software from developer "Silicon Laboratories Inc" was blocked from loading").  I am sure that I missing something simple, but I can't figure out what.  Can anyone tell me what I am missing?


locked Re: Easiest transceiver/computer combo to configure for FT8 #install

Ed W2LCQ
 

Hi Tom,

I forgot to mention I’m using an Icom 7300 a very easy rig to work with. CAT and AFSK is done over one USB cable. The 7300 has a built in sound card. It is very stable.  All I had to do was install the Icom driver into Windows which was a very easy download from Icom site. I use WSJT-X most of the time with DXLab Suite which does the logging. I also use it with N1MM+ for contests. Good luck. 

73, de W2LCQ, Ed Jones

”New York is where I am.” —- James Dean

On Mar 26, 2021, at 6:38 PM, Tom Arny <tarny@...> wrote:

Hi John,



locked Re: Easiest transceiver/computer combo to configure for FT8 #install

Tom Arny
 

Hi John,


locked Re: 2.4 rc4 and FTDX101MP #Cat_RigControl

Bill Somerville
 

On 26/03/2021 18:07, Buddy Morgan via groups.io wrote:
Downloaded 2.4 rc4. It works fine with my IC 9700 and my IC 7100. Still can't get any version of 2.4 to work with my FTDX101MP. 2.2 worked fine with the FTDX101MP. I tried an early version of 2.3 and it did not work with the '101.
I get the following error message,from 2.4 rc4:

Hamlib error: Feature not implemented
newcat_set_freq: special_60m=0, 60m freq=0, is_ftdx3000=0
newcat.c(784):newcat_set_freq return(-4)
rig.c(1724):rig_set_freq return(-4) while setting frequency

Timestamp: 2021-03-26T16:37:57.789Z

I would really like to get it working with my FTDX101. I am using Windows 10, on a HP All-In-One. I have not changed any settings on either the radio or the WSJT software.
Any ideas?

Buddy WB4OMG

Hi Buddy,

so I can see what is happening, please put the attached file into the WSJT-X configuration files directory (on MS Windows the configuration files directory is the same one as the log file directory "Menu->File->Open log directory"). Then restart WSJT-X, execute the minimum steps to reproduce the issue, then quit WSJT-X. It will have created a file on your Desktop called WSJT-X_RigControl.log , send me that file for analysis (g4wjs <at> classdesign <dot> com). Once you have sent the log file you can delete the log file from your Desktop, and delete the log configuration file to return to normal WSJT-X operation.

73
Bill
G4WJS.


locked Re: WSPR receiving bandwidth adjustment? #WSPR

Bill Somerville
 

On 26/03/2021 18:09, Bruce KX4AZ wrote:
Now and then I see a poor little WSPR signal coming in just outside of the 1400-1600 Hz standard bandwidth, so it won't be decoded as far as I understand.  Wondering if there is any kind of setting in WSJTx that would allow me to pad the upper/lower audio edges, say to add an extra 20 Hz on each end?

Of course I could simply shift the entire slot up/down by changing my receiver frequency, but then I would be chopping signals at one of the ends.
Hi Bruce,

are you sure it is WSPR? FST4W signals can often be found near the WSPR sub-bands.

73
Bill
G4WJS.


locked #FST4W FST4[W] Beacon Source #FST4W

Andy Talbot
 

The PIC/DDS beacon source is now running, and it's being tested  on air for the first time with FSTW-120, -300 and now -900 

There's just have one issue to sort out.   I generate the Gaussian glide by using just two adjacent symbols and adding their weighted components based on a lookup table, sampled at 64* the sample rate.
Doing it like that means each session starts half a symbol late.   For the faster modes this doesn't matter, it's less than a second on DT.  On FSTW-900 the resulting delay of half a symbol is 2.8 seconds - which the decoder seems able to cope with but on -1800 the delay, DT,  becomes 5.6 seconds which doesn't work.

I can sort this by doing the job properly, and adding weighted versions of three symbols, last, this and next.  A few more lines of code, but easy enough to do

and.. as I write ... just checked WSPRNET, and there's a decode of the first -900 signal off air.   It works !


locked Re: No Tx audio after inactivity. #AudioIssues

Pete Singleton
 

Hi Phil,
I understand the USB port may need 'power management'.  I'd already turned that off.  This is about the driver software that uses the port.  Why does that ALSO need power management?

73 PeteS

On Fri, 26 Mar 2021 at 13:18, Philip Rose via groups.io <gm3zza=btinternet.com@groups.io> wrote:

It’s not the software, it’s the USB hardware that consumes power, regardless of whether it is active. Current laptops try and remove every single “unnecessary” use of power.

 

73 Phil.

 

Sent from Mail for Windows 10

 

From: Pete Singleton
Sent: 25 March 2021 18:04
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] No Tx audio after inactivity. #AudioIssues #txaudio

 

Update: I discovered that the 'CP210x USB to UART Bridge' had 'Allow power management' turned on.  Unticked the box and Tx audio stays alive during inactivity.

I don't understand how a minor bit of software can drain power.

I'm still getting the 'no Tx audio after band change' problem - new in v2.3.0

I REALLY, REALLY hate Win10.

73 de M0PTB
PeteS

 


--
73 Phil GM3ZZA



locked WSPR receiving bandwidth adjustment? #WSPR

Bruce KX4AZ
 

Now and then I see a poor little WSPR signal coming in just outside of the 1400-1600 Hz standard bandwidth, so it won't be decoded as far as I understand.  Wondering if there is any kind of setting in WSJTx that would allow me to pad the upper/lower audio edges, say to add an extra 20 Hz on each end?

Of course I could simply shift the entire slot up/down by changing my receiver frequency, but then I would be chopping signals at one of the ends.


locked Re: 2.4 rc4 and FTDX101MP #Cat_RigControl

Buddy Morgan
 

Downloaded 2.4 rc4. It works fine with my IC 9700 and my IC 7100. Still can't get any version of 2.4 to work with my FTDX101MP. 2.2 worked fine with the FTDX101MP. I tried an early version of 2.3 and it did not work with the '101.
I get the following error message,from 2.4 rc4:

Hamlib error: Feature not implemented
newcat_set_freq: special_60m=0, 60m freq=0, is_ftdx3000=0
newcat.c(784):newcat_set_freq return(-4)
rig.c(1724):rig_set_freq return(-4) while setting frequency

Timestamp: 2021-03-26T16:37:57.789Z

I would really like to get it working with my FTDX101. I am using Windows 10, on a HP All-In-One. I have not changed any settings on either the radio or the WSJT software.
Any ideas?

Buddy WB4OMG

13141 - 13160 of 36726