locked Re: Rig Control error with FT-857D


Bill Somerville
 

Hi Allan,

there are two contributory factors to the issue, firstly the FT-817/857/897(D) series of rigs refuse to process CAT QSY commands while transmitting, and secondly using an external keying device like the SignaLink USB makes it impossible for WSJT-X to determine exactly when the rig is in Tx mode. You may have noticed that the issue occurred at the point of returning to Rx, the issue being that the SignaLink USB holds the rig in Tx while WSJT-X thinks it is in Rx mode and safe to send CAT QSY commands. By using CAT PTT commands and reducing the VOX delay on the SignaLink USB to minimum, the transmit timing is more deterministic and reliable.

73
Bill
G4WJS.

On 21/12/2019 04:18, Allan Cooke via Groups.Io wrote:

Hi Bill,

First, I want to thank you for your very quick response!

Second....wow!! Your suggestions completely fixed the problem! I cannot tell you how frustrating this has been for me to try and solve this. I will spend some time going over the parameters you told me to change and try to understand why those made the difference.

I don’t want to take up any more of your time, but as a retired Central Office technician from Verizon for 35 years, I would love to hear the explanation about what was happening that was causing this. I spent my entire career trouble shooting all kinds of telephone switching troubles and it is frustrating when I can’t solve an electronics or computer trouble.

Anyway....THANK YOU so much for your answers in solving this trouble!!

All is well now and I can sleep peacefully once again....hihi

A big 73,

Allan KB3AC



Sent from my iPad

On Dec 20, 2019, at 2:26 PM, Bill Somerville <g4wjs@...> wrote:

On 20/12/2019 18:46, Allan Cooke via Groups.Io wrote:
WSJT-X is working fine with my Yaesu FTdx-1200 but I am not able to use WSJT-X with my Yaesu FT-857D. Anytime I transmit, either by clicking the TUNE button or try to answer a CQ by double clicking the message, I get a Rig Control Error. When I click on Details, it says Hamlib error: Command rejected by the rig while setting frequency.
 I am using the latest WSJT-X version 2.1.2 with Windows 10 on a HP laptop. I cannot remember if I have used this rig with previous versions.
 I have two FT-857D’s and both rigs display the same error. I can use this rig with Fldigi and the same Hamlib settings and it works fine. It appears to work okay with WSPR version 2.1.2 and I do not receive any error messages.
 I am able to select FT-857 from the Rig dropdown menu. When I click on Test CAT, it turns green. I am using a COM4 port, Baud rate of 4800, 8 data bits, one stop bit, and Handshake of None. The PTT is set for VOX and the mode is USB. Split Operation is None. I can change the frequency on the rig and the change is reflected in the program. I can also change the frequency in the program and it will in turn change the frequency of the rig without any problems. I am using a Signalink for the audio which is sending and receiving without any problems.

When I double click a CQ message, it will transmit for a few seconds, then stops transmitting and shows the error message. When I click on TUNE, it will continue to transmit for any length of time until I click it again to stop transmitting, then I get the error message.

Thanks for any suggestions!
 73,
 Allan Cooke
KB3AC
Hi Allan,

make sure that the WSJT-X option "Settings->General->Behavior->Allow Tx frequency changes while transmitting" is *not checked*.

Set the WSJT-X option "Settings->Radio->PTT Method->CAT" and reduce the delay knob on the SignaLink USB interface to minimum.

I also recommend setting the WSJT-X option "Settings->Radio->Split Operating" to "Rig" and "Settings->Radio->Mode" to "Data/Pkt", making sure that USER U is set as the DIGI mode on your rig.

73
Bill
G4WJS.


Join main@WSJTX.groups.io to automatically receive all group messages.