locked Rig Control error with FT-857D


Allan Cooke
 

WSJT-X is working fine with my Yaesu FTdx-1200 but I am not able to use WSJT-X with my Yaesu FT-857D. Anytime I transmit, either by clicking the TUNE button or try to answer a CQ by double clicking the message, I get a Rig Control Error. When I click on Details, it says Hamlib error: Command rejected by the rig while setting frequency.

I am using the latest WSJT-X version 2.1.2 with Windows 10 on a HP laptop. I cannot remember if I have used this rig with previous versions.

I have two FT-857D’s and both rigs display the same error. I can use this rig with Fldigi and the same Hamlib settings and it works fine. It appears to work okay with WSPR version 2.1.2 and I do not receive any error messages.

I am able to select FT-857 from the Rig dropdown menu. When I click on Test CAT, it turns green. I am using a COM4 port, Baud rate of 4800, 8 data bits, one stop bit, and Handshake of None. The PTT is set for VOX and the mode is USB. Split Operation is None. I can change the frequency on the rig and the change is reflected in the program. I can also change the frequency in the program and it will in turn change the frequency of the rig without any problems. I am using a Signalink for the audio which is sending and receiving without any problems.

When I double click a CQ message, it will transmit for a few seconds, then stops transmitting and shows the error message. When I click on TUNE, it will continue to transmit for any length of time until I click it again to stop transmitting, then I get the error message.

Thanks for any suggestions!

73,

Allan Cooke
KB3AC

Join main@WSJTX.groups.io to automatically receive all group messages.