Locked Re: Dependacy is not #hamlib

Bill Lederer

I get the boost error when installing the .deb on ubuntu 22. Unclear what
to install go get this to work.

On Mon, Sep 12, 2022 at 5:43 AM Rick Chapman <gm4jib@...> wrote:


LM20 is based on Ubuntu 20.04 so it will return libboost 1.71


It's not a good idea to try shoe horn in libraries above the the repo
level, you'd likely create problems in other apps requiring the repo
level. Best not go that way.

Your problem is that WSJT-X 2.6.0-rc4 requires Ubuntu 22.04 (although
the web page says Ubuntu 20.04 LTS), as has been mentioned before (might
have been on the developers forum)

If you want to use the deb package you'll have to upgrade to Linux Mint
21 which is based on Ubuntu 22.04

Alternatively, you can still use LM 20 if you build from sources. it's
easy, I've done it. It took 4 minutes on my workstation and 7 mins on
my old laptop. And it works just fine. There are scripts to do it. I
have attached one. It will install all the tools, compilers etc and any
library dependencies you need too. There are more on the forum. Glad
to help if you need any.



Rick (GM4JIB)

On 12/09/2022 04:23, Michael Black via groups.io wrote:

apt list | grep libboost
Hopefully shows libboost1.74-dev
Mike W9MDB

On Sunday, September 11, 2022 at 08:29:12 PM CDT, Bill Lederer <
w8lvn.9@...> wrote:

Ok, here is my result:

root@w8lvn:~# apt install libboost
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libboost

Trying to install the new package itself:

root@w8lvn:/home/wgl/Downloads# dpkg -i wsjtx_2.6.0-rc4_amd64.deb
(Reading database ... 402747 files and directories currently installed.)
Preparing to unpack wsjtx_2.6.0-rc4_amd64.deb ...
Unpacking wsjtx (2.6.0-rc4) over (2.5.4+repack-1) ...
dpkg: error processing archive wsjtx_2.6.0-rc4_amd64.deb (--install):
trying to overwrite
'/usr/share/doc/wsjtx/example_log_configurations/README', which is also
package wsjtx-doc 2.5.4+repack-1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu3) ...
Errors were encountered while processing:

Please advise.

On Sun, Sep 11, 2022 at 6:18 PM Michael Black via groups.io <mdblack98=
yahoo.com@groups.io> wrote:

You need to update libboost.
Check to see if a new package is available.
Mike W9MDB

On Sunday, September 11, 2022 at 10:26:58 AM CDT, Denton Larson <
wb0zur@...> wrote:


Linux mint 20.3 gives me
Dependacy is not satisfiable libboost -filesystems 1.74.0 (>= 1.74.0)
I did look but got fustrated,
Help please!

WB0ZUR Denton


Join main@WSJTX.groups.io to automatically receive all group messages.