locked Re: Trouble with Yaesu FT-747GX CAT #windows11 #Cat_RigControl #hamlib


kedrot@...
 

Unfortunately that leads into a weirder behavior; it initially set my
rig to the right frequency , but then it started to drift from 707,46
to 74,6000 to 746000 and so on, then it randomly started enabling PTT.

I'd send debug info but I don't know how to obtain that from Windows' WSXJT.

On Wed, 17 Aug 2022 at 13:45, Michael Black via groups.io
<mdblack98@...> wrote:

Please try this DLL....I just made a change that should help this....
https://www.dropbox.com/s/7aejdv74nfjxr0q/libhamlib-4.dll?dl=0


And if it still is wrong (which it likely will be) please provide debug info

New hamlib for installation directions

#1 Shut down WSJTX

Linux/Unix/Mac users need to compile the latest tar file from http://n0nb.users.sourceforge.net/\
Note: If compiling on Unix-like systems please uninstall any Hamlib package you have before installing the new build

#2 If you don't save directly you need to open a file browser and move the file that way.

If you're not familiar with that here's a video on the file browser - https://www.youtube.com/watch?v=AyVqCJrs9dk

Mike W9MDB









On Wednesday, August 17, 2022 at 12:47:55 AM CDT, kedrot@... <kedrot@...> wrote:





I'm trying to setup CAT to control my rig; my settings are:

COM4
8 data bits
2 stop bits
no handshake
other pins on default

The Test CAT button works, it sets to green, and PTT also correctly starts transmitting.

The issues:

When selecting a band from the dropdown, the rig is correctly set to the appropriate frequency. A couple of seconds later, when the system polls the current frequency, it's 100 times higher and it ends in 48. E.g.: 40m sets to 7,074.000 Two seconds later, it becomes 707,400.048.

A few seconds later, I get a timeout error and the rig disconnects.

Any help is appreciated.









Join main@WSJTX.groups.io to automatically receive all group messages.