locked Re: Test CAT - Button stays white, no error messages #Cat_RigControl


Mike Ward
 

Mike,

I installed hamlib 4.5 and the wsjtx_log_config file, attempted to make an ft8 connection but it still fails.  I'm attaching the rig control log.  Thanks!!!

I'm new to the Groups application so I'm learning how to communicate and attach files.  Hopes this works.

Mike Ward, KE0KAC

On 6/21/22 11:58, Michael Black via groups.io wrote:
New hamlib for installation directions


#1 Shut down WSJTX/JTDX
#2 Download either the 32-bit or 64-bit DLL matching the 32/64-bit version of WSJTX/JTDX -- hopefully your browser doesn't block it but may warn you multiple times.

If you can do a "Save As" you can save it directly in \WSJT\WSJTX\bin and replace the libhamlib-4.dll that is there.

http://n0nb.users.sourceforge.net/dll32/libhamlib-4.dll
http://n0nb.users.sourceforge.net/dll64/libhamlib-4.dll

Linux/Unix/Mac users need to compile the latest tar file fromhttp://n0nb.users.sourceforge.net/\
Note: If compiling on Unix-like systems please uninstall any Hamlib package you have before installing the new build

#3 If you don't save directly you need to open a file browser and move the file that way.

If you're not familiar with that here's a video on the file browser -https://www.youtube.com/watch?v=AyVqCJrs9dk

If you still see these warnings.....
Please place this file as described below
https://www.dropbox.com/s/t52ngcalsgnpm8m/wsjtx_log_config.ini?dl=0


    C:\Users\[username]\AppData\Local\WSJT-X
    The WSJT-X_Rigcontrol.log file will be in the same location
For Linux put it in
    ~/.config
    The WSJT-X_Rigcontrol.log file will be here:
    ~/.local/share/WSJT-X
Restart WSJT-X and duplicate the problem.
Shut down WSJT-X


Then send me the WSJT-X_RigControl.log file


Mike W9MDB








On Tuesday, June 21, 2022, 11:55:11 AM CDT, Mike Ward<woooe48mmex991@...> wrote:





Yes, I carefully set the mic adjustment to show the flickering 5th bar.

I had a look at wsjtx_syslog.log and set the following errors which appear to be logged once a minute.

[RIGCTRL][2022-06-18 19:46:10.602969][01:12:58.859075][warning] kenwood_get_split_vfo_if(1582): unknown rxVFO=None
[RIGCTRL][2022-06-18 19:46:11.610320][01:12:59.866426][warning] kenwood_get_split_vfo_if(1582): unknown rxVFO=None
[RIGCTRL][2022-06-18 19:46:12.601723][01:13:00.857830][warning] kenwood_get_split_vfo_if(1582): unknown rxVFO=None
[RIGCTRL][2022-06-18 19:46:13.608646][01:13:01.864752][warning] kenwood_get_split_vfo_if(1582): unknown rxVFO=None
[RIGCTRL][2022-06-18 19:46:14.600119][01:13:02.856225][warning] kenwood_get_split_vfo_if(1582): unknown rxVFO=None
[RIGCTRL][2022-06-18 19:46:15.607600][01:13:03.863707][warning] kenwood_get_split_vfo_if(1582): unknown rxVFO=None
[RIGCTRL][2022-06-18 19:46:16.599185][01:13:04.855291][warning] kenwood_get_split_vfo_if(1582): unknown rxVFO=None
[RIGCTRL][2022-06-18 19:46:17.606492][01:13:05.862598][warning] kenwood_get_split_vfo_if(1582): unknown rxVFO=None
[RIGCTRL][2022-06-18 19:46:18.613792][01:13:06.869899][warning] kenwood_get_split_vfo_if(1582): unknown rxVFO=None
[RIGCTRL][2022-06-18 19:46:19.605377][01:13:07.861484][warning] kenwood_get_split_vfo_if(1582): unknown rxVFO=None

The errors mention kenwood but my radio is an Elecraft KX3.  I have configured WSJT-X for Rig: Elecraft KX3.

Mike, KE0KAC








Join main@WSJTX.groups.io to automatically receive all group messages.