locked Re: FT857 Rig control problem #hamlib


Karza
 

Don,

When started with parameter "--rig-name=FT857"  WSJT-X will store coniguration into file named
'WSJTX - FT857.ini'. This file is stored in directory '~/.config'. You should place file 'wsjtx_log_config.ini' into  '~/.config' too.

The 'WSJT-X_RigControl.log' file will then be created in directory '~/.local/share/WSJT-X - FT857'.

HTH de Kari, oh2gqc


You should place the

On 9.3.2022 0.04, d_ziolkowski wrote:
Mike --

Found wsjtx.ini in ~/.wsjtx.

placed the log.ini in that folder.

ran test as directed, no log generated.

Perhaps you need to know that the ft857 runs wsjtx --rigname=FT857.

~/.wsjtx$ ls
afmhot.dat in.dat save wsjtx.ini
ALL.TXT jt9 shortcuts.txt wsjtx_log_config.ini
blue.dat jt9.txt timer.out wsjtx_status.txt
CALL3.TXT kvasd.dat wsjtx
decoded.txt mouse_commands.txt wsjtx_changelog.txt

Thanks DAN kc2sta



On Tue, Mar 8, 2022 at 3:24 PM Michael Black via groups.io <mdblack98=
yahoo.com@groups.io> wrote:

The you didn't put the file in the right place.
Should be the same location as the WSJT-X.ini file wherever your system
put that.



On Tuesday, March 8, 2022, 01:18:05 PM CST, d_ziolkowski <
dan.ziolkowski@...> wrote:

Mike

Error occurred again, did as email directed, but no rigcontol.log file is
generated.

Dan KC2STA

On Mon, Mar 7, 2022 at 4:17 PM Michael Black via groups.io <mdblack98=
yahoo.com@groups.io> wrote:

Please place this file in
~/.local/share/WSJT-X
https://www.dropbox.com/s/t52ngcalsgnpm8m/wsjtx_log_config.ini?dl=0
Restart WSJT-X and duplicate the problem.Shut down WSJT-X
Then send me the WSJT-X_RigControl.log file that will be in the same
location.
Mike W9MDB




On Monday, March 7, 2022, 03:14:01 PM CST, d_ziolkowski <
dan.ziolkowski@...> wrote:

Running WSJTX-2.5.4 on Ubuntu 18.04. Rig FT-857.

Upgraded to this version a couple weeks ago, and all was fine. PC runs
24/7.

Today when I loaded wsjtx and transmitted, I received this Error:
=======================================
Hamlib error: Command rejected by the rig
0000 f0 .
ft817_read_ack: ack received (240)
rig.c(1571):rig_set_freq return(-9) Command rejected by the rig
0000 f0 .
ft817_read_ack: ack received (240)
ft817_read_ack: ack received (240) while setting frequency

Timestamp: 2022-03-07T18:40:57.283Z
===================================

Seems odd that the error references an ft817, but rig is set to FT857. I
also set rig to NONE, then back to FT857, still problem.

After the error, I then hit retry and back to normal, until next xmit,
problem repaets.

I reduced power to rig from 60 watts , to 5 watts, same problem.

Connected dummy load , same problem at 5 watts

Also problem occurs AFTER transmit ends. Not while transmitting.

SO I re-installed wjtx, but same problem.

PC reboot does not fix problem either.

I tried FLrig, and no problems with control.

Any help is appreciated,

Thanks Dan KC2STA











--
Dan Ziolkowski KC2STA
SKCC #4290T
Ubuntu LINUX











Join main@WSJTX.groups.io to automatically receive all group messages.