locked Re: Kenwood TS-2000 - no TX-NF in Versions above 2.3.1 #IssueReport #Kenwood #linux #Cat_RigControl #txaudio


Don Roden
 

Do NOT use CAT

Do NOT use CAT

Do NOT use CAT

All TS-2000 owners !!

Do NOT use CAT

W4DNR

On 2022-01-23 3:19 pm, Karl Beckman WA8NVW - AFA5VB wrote:

STEFAN -
The "No Audio from Rear Panel" condition exists when you inject PTT via either CAT command or serial RTS logic low to the Mic PTT line. Either signal mutes the TS2000 rear panel audio input; Then transmit audio is accepted only from the TS2000 front panel Mic connector. This is working exactly as designed and documented by Kenwood from day one and was not modified in any subsequent firmware update. Since the rear panel audio input signal is disabled, the TxMon feature sends nothing to the speaker. The pre-selected defaults for WSJTx that appear when the user runs the setup and chooses Knwd TS2000 as the radio model would have worked correctly from the beginning (which at my station was WSJTx 1.8 a few years ago).
The good news is that you have no less than two other methods to get your TS-2000 setup working properly with WSJTx: These two are my first thoughts, and others here probably have even better ways to get you on the air again. So dig out your TS2000 manual and thumb back to page 95 for interfacing an MCP or TNC to the radio.
Method 1) In WSJT change the Radio PTT setting to VOX, DO NOT USE CAT!! Remember, a CAT PTT or a station PTT (pin 13) will ALWAYS mute the rear panel ACCY2 jack audio input and unmute the front panel mic jack.
OR
Method 2)
If uou MUST use an RTS PTT signal instead of VOX, rewire your RTS PTT lead to pin 9 of the rear panel ACCY2 jack, used for PKS or Packet Send. The corresponding transmitter audio input is PKD or Packet Data. NOTE: That is the ONLY point you can apply the PTT signal and get modulation routed into the transmitter. The ground return for both lines is pin 8 or pin 12 on the 13-pin DIN connector.
CAUTION: The 13-pin DIN plug can be inserted upside down without causing smoke. Ignore any arrows on the molded plug body. Check it visually! Again, be sure you disable CAT control and use only the VOX or PTT option in WSJTx.
MIKE W9MDB -
Stefan's issue has nothing to do with the recent updates or any coding of Hamlib inside WSJTx, It is simply a peculiarity of the Kenwood TS2000.station which has been known since the rig debuted over two decades ago. Indeed, Stefan CAN'T use any source of CAT commands to get WSJTx transmitting in his station. CAT is itself the root cause of his missing Tx audio problem.
73 & gud DX in Cycle 25
--
Karl WA8NVW OH
WA8NVW@...
in WSJTX@groups.io

Join main@WSJTX.groups.io to automatically receive all group messages.