Re: new version 25 doesnt switch ic9100 to usb-d mode #Cat_RigControl #Icom


Bill Somerville
 

Mike,

WSJT-X always requests a mode change with no change in the filter settings. I know this is somewhat problematic with some Icom rigs that do not allow reading the filter settings on the SPLIT Tx VFO without swapping VFOs. Perhaps those that want to use the Icom default filter settings and can't be bothered to customize them as needed should be forced to put up with VFO swapping when changing modes in SPLIT, so Hamlib can read the current filter settings and honour the RIG_PASSBAND_NOCHANGE option by reading the current value to reuse just before setting the mode.

Note that WSJT-X always requests a mode switch (possible redundant) when setting the frequency, this will not change as it copes well with inadvertent operator mode changes via the front panel.

73
Bill
G4WJS.

On 15/10/2021 16:47, Michael Black via groups.io wrote:
I've gone back and forth with Icom several times....

Their default mode is filter 2 and I used to force it to filter 1.  I changed hamlib to let the rig default to whatever it wants and if Icom ever fixes that (not holding my breath) so that the filter follows the band stack then everybody will be happy.

Meanwhile you need to set filter 2 to your data mode wide filter.

My other choice is to do same as FLRig and "remember" whatever filter you select but hamlib currently doesn't try to remember anything so would be a significant change to having hamlib save a config file.

Mike W9MDB




On Friday, October 15, 2021, 10:24:58 AM CDT, bob lee <ve3cga@...> wrote:


Hi Bill, well just about there.
the usb-d mode is now selected going into wsjtx
however the rig is put into filter 2 which really narrows the field of view
additionally it leaves the USB mode in filter#2 as version 24 does as I found out yesterday (below)

Running version 24 I never realized it (originally thought it had been previously set by me) but although it starts up just fine with usb-d mode & filter set at #1, when I exit and manually switch back out of data mode, whatever band was selected with wsjt-x is left in filter #2 even though wsjt-x ran in data mode with the filter set to filter #1.
In other words, with wsjtx exited, manually switching to usb mode the filter is now filter #2. Manually switching back to data mode shows filter #1 (good)

I dont know if the data mode ON cmd $FEFE7cE01A060101FD could be inserted into the 9100 configuration 
Different program but I have do this with mmsstv radio commands for each bands then I deselect, put mode back to USB with filter untouched: $FEFE7cE01A060000FD

From the manual pg 193:

 
I wonder if there is somewhere in the wsjtx files where I could insert these command strings

tnx Bob VE3CGA


Join main@WSJTX.groups.io to automatically receive all group messages.