Re: Possible DXL Commander defect with IC-9700 and WSJTx #Cat_RigControl


Bob Turner
 

Bill,

 

WSJTx v2.5.0-rc6.  I got this from Mike when we were working on 7610 with same filter problem.  I upgraded in an attempt to fix 9700.

IC-9700 VFO-A and VFO-B set to Fil1.

Hit tune.  It TX on VFO-B Fil1, split light is on rig.  After TX split light goes out, I end up on VFO-A set to Fil2.

 

You will see an extra relaunch of WSJTx at end of log as I forgot which instance of multiple log directories to get the file from.

 

Log file is attached.

 

All,

 

I see your comments.   Thank you.  Very interesting.  I’ll work directly with Bill for now.

 

7 3  Bob

N2SCJ

 

 

From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Bill Somerville
Sent: Tuesday, September 14, 2021 10:55 AM
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Possible DXL Commander defect with IC-9700 and WSJTx #Cat_RigControl

 

Hi Bob,

 

that would appear to be an issue with N1MM Logger+. So I can be sure please put the attached file into the log files directory of the WSJT-X instance that is using N1MM Logger+ for rig control ("Menu->File->Open log directory"), quit WSJT-X, restart WSJT-X, replicate the issue with the minimum number of steps, then quit WSJT-X. It will have created a log file called WSJT-X_RigControl.log on your Desktop. Send me (g4wjs <at> classdesign <dot> com) that log file for analysis please?

 

Once you have sent me the log file you can delete it and the log configuration file to return to normal operation.

 

73
Bill
G4WJS.

 

On 14/09/2021 15:47, Bob Turner wrote:

Bill,

 

I stand corrected.  I was running in non-contest config when I answered that.  I went back to N1MM then launched WSJTx from within N1MM.  The correct answer is Mode=None.

 

I start my test with rig manually set to USB-D and Fil1.  I am RX on VFO-A.  Split on light on rig is off.  During TX on VFO-B rig split light comes on.  After TX, rig split light goes out, I’m back on VFO-A and on Fil2.

 

Bob

 

From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Bill Somerville
Sent: Tuesday, September 14, 2021 10:36 AM
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Possible DXL Commander defect with IC-9700 and WSJTx #Cat_RigControl

 

Hi Bob,

 

OK, so if you change that to Mode->None does the issue you initially reported go away?

 

73
Bill
G4WJS.

 

On 14/09/2021 15:33, Bob Turner wrote:

Mode=Data/Packet.  Not sure how I ended up with that setting.

 

73  Bob

N2SCJ

 

From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Bill Somerville
Sent: Tuesday, September 14, 2021 10:30 AM
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Possible DXL Commander defect with IC-9700 and WSJTx #Cat_RigControl

 

Bob,

 

I asked about the "Settings->Radio->Mode" option. You stated you set the rig mode manually. I asked if you had the "Settings->Radio->Mode->None" option checked. I asked that because with that configuration WSJT-X should not be making any mode or filter changes on you rig. I am trying to determine if there is a defect where using the "Settings->Radio->Mode->None" option is somehow causing the filter settings to change on your rig.

 

73
Bill
G4WJS.

 

On 14/09/2021 15:25, Bob Turner wrote:

Bill,

 

Non contest I use HRD Logger.  HRD is not involved with rig control.   In addition HRD Logger is on a different network PC.  I let WSJTX deal directly with IC-9700.   Win4ICOM is port sharing.  All is ok in this configuration.

 

Contest I use N1MM for logging and rig control.   WSJTx asks N1MM to do what it needs.  WSJTx needs to use DXL Commander as the rig.  My intention was to let WSJTx do full control with Split=Rig.   I want WSJTx to change frequency as needed to as to cut off/minimize any birdies I may generate.   Then I noticed I can’t RX on Filter 1 / Wide.  I can set it to that for one RX cycle, then after TX ends, RX goes to Filter 2 and stays there.  I changed to Split=Fake It.  Problem went away.  This is an acceptable workaround for me.    I never tried Split=None as I assume that would leave my TX frequency unchanged.  I could be wrong with this assumption.

 

I recently worked with Mike W9MDB on a can’t use Filter1 for RX issue with IC-7610.  If you need me to do any further testing or have info for me, please let me know.

 

7 3  Bob

N2SCJ

 

 

 

 

 

From: main@WSJTX.groups.io [mailto:main@WSJTX.groups.io] On Behalf Of Bill Somerville
Sent: Tuesday, September 14, 2021 6:09 AM
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] Possible DXL Commander defect with IC-9700 and WSJTx #Cat_RigControl

 

On 14/09/2021 05:13, Bob Turner wrote:

While using N1MM for rig control which I understand emulates DX Labs Commander I ran into the following issue with WSJTx.  WSJTx uses DX Labs Commander Suite as the rig.   For the rig I am using Rig=Split.  I manually set mode to USB-D, then set VFO-A and VFO-B to Filter 1 (wide).  Starting on VFO-A.  When WSJTx TX it tx on VFO-B with Filter 1.  So far so good.  When TX ceases I’m back on VFO-A on Filter 2.  I wish to remain on Filter 1 for RX as there are more signals to decode.  This may be a defect.

 

My workaround is to set Split Operation to rig=fake it.  This allows me to stay on Filter 1 for RX.

 

Assuming my understanding of this issue is correct, I’m hoping it can be addressed at some point.

 

7 3  Bob

N2SCJ

Hi Bob,

if you are manually setting the rig's mode then I assume you have "Settings->Radio->Mode->None" checked in WSJT-X. With that setting WSJT-X should not be making any changes to the rig's mode or filter settings. Please confirm that if that is not the case.

73
Bill
G4WJS.

 

Join main@WSJTX.groups.io to automatically receive all group messages.