locked Re: #Cat_RigControl #linux #install #Cat_RigControl #linux #install


richard kappler
 

Thanks to all, its running now.

Rich
W2KAP

On Fri, Aug 20, 2021 at 10:59 AM Michael Black via groups.io <mdblack98=yahoo.com@groups.io> wrote:
Sounds like your baud rate is wrong.

Double check the baud rate on the rig.

Mike W9MDB




On Friday, August 20, 2021, 09:54:46 AM CDT, richard kappler <richkappler@...> wrote:


Well... That's an improvement. Now I have a new error :-)

Hamlib error: Communication timed out

rig_get_freq(2088): freqMainA=0, modeMainA=, widthMainA=0

rig_get_freq(2088): freqMainB=0, modeMainB=, widthMainB=0

rig.c(2090):rig_get_freq return(-5) while getting current frequency


On Fri, Aug 20, 2021 at 10:29 AM Stan Gammons via groups.io <buttercup11421=protonmail.com@groups.io> wrote:
At the command line is dialout in the list when you type groups and press enter?  If not you need to add yourself to the dialout group. Type sudo usermod -a -G dialout $USER and press enter. Then you have to logout and log back in for the change to be recognized.

hth

73

Stan
KM4HQE 

Sent from ProtonMail for iOS


On Fri, Aug 20, 2021 at 8:48 AM, richard kappler <richkappler@...> wrote:
I feel like an idiot that I can't figure this out.

Rig: IC-7300 to Toshiba laptop via USB running Ubuntu 20.04, fresh install of wsjt-x 2.4

dmesg output:
[69126.656469] usb 3-4.1: new full-speed USB device number 15 using xhci_hcd
[69126.758625] usb 3-4.1: New USB device found, idVendor=10c4, idProduct=ea60, bcdDevice= 1.00
[69126.758628] usb 3-4.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[69126.758630] usb 3-4.1: Product: CP2102 USB to UART Bridge Controller
[69126.758632] usb 3-4.1: Manufacturer: Silicon Labs
[69126.758633] usb 3-4.1: SerialNumber: IC-7300 02013977
[69126.760521] cp210x 3-4.1:1.0: cp210x converter detected
[69126.762472] usb 3-4.1: cp210x converter now attached to ttyUSB0
[69126.840479] usb 3-4.4: new full-speed USB device number 16 using xhci_hcd
[69126.943745] usb 3-4.4: New USB device found, idVendor=08bb, idProduct=2901, bcdDevice= 1.00
[69126.943749] usb 3-4.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[69126.943752] usb 3-4.4: Product: USB Audio CODEC
[69126.943754] usb 3-4.4: Manufacturer: Burr-Brown from TI              
[69126.962874] input: Burr-Brown from TI               USB Audio CODEC  as /devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4.4/3-4.4:1.3/0003:08BB:2901.0005/input/input28
[69127.020858] hid-generic 0003:08BB:2901.0005: input,hidraw1: USB HID v1.00 Device [Burr-Brown from TI               USB Audio CODEC ] on usb-0000:00:14.0-4.4/input3

Rig Failure error:

Hamlib error: IO error

port_open: serial_open status=-6

iofunc.c(80):port_open return(-6)

rig.c(773):rig_open return(-6) while opening connection to rig


File > Settings > Radio:

RadioSettings.png


File > Settings > Audio:

audioSettings.png


My google foo is giving me no joy. Can someone please throw an old dog a bone? I can't figure out what I'm missing.


Rich

W2KAP












Join main@WSJTX.groups.io to automatically receive all group messages.