locked Re: #Kenwood #Cat_RigControl #Kenwood #Cat_RigControl


neil_zampella
 

You can't compare another program with WSJT-X unless its using Hamlib as the interface.   Reinstalling the program doesn't solve anything as this appears to be an configuration issue.

You talk about 'controlling' the rig, but then you mention sound cards, which have nothing to do with it.

Please let us know what you're using to interface the rig with computer for CAT control (if any) and how are you connecting for audio.

Neil, KN3iLZ

On 8/6/2021 4:08 PM, Chris wrote:
v 2.4.0
A few months back, WSJT-X stopped controlling my Kenwood TS-450.  I didn't have time or patience to trouble shoot at that time.  Now I'm ready to dive into it.

First, I believe this is a problem with the Kenwood library, because the program continues to work fine with my Yaesu FT-817.  Also the error message indicates this. Another program (Mixw-4) using the same com ports is able to control the Kenwood fine. 

The big mystery is why, when it once worked fine with the Kenwood, it stopped working suddenly.

What I have tried:

Re-installing (more than once)
Trying different com ports (because I had an issue with enumeration of the sound card once before)
Clearing and re configuring the settings.
Refreshing windows 10 with a repair upgrade.

None of this worked.  I could use a hint from someone who really understands how the rig library works and how one can fix or update it.

Chris, AB6QK


Join main@WSJTX.groups.io to automatically receive all group messages.