locked Re: IC-9700/7300 VFO A/B switching #Cat_RigControl


Brad, K8ZM
 

Brian,

Thanks for the info and link, much appreciated !!

Brad, N8GLS

Sent from my Samsung Galaxy S10 "not so" Smartphone


-------- Original message --------
From: Brian Morrison <bdm@...>
Date: 7/6/21 12:40 PM (GMT-05:00)
To: main@WSJTX.groups.io
Subject: Re: [WSJTX] IC-9700/7300 VFO A/B switching #Hamlib

On Tue, 2021-07-06 at 11:56 -0400, Brad, N8GLS wrote:

Been using v2.4.0 for a while and have noticed the following occurring;

 

IC-9700:  When WSJT-X launches it consistently will switch the 9700’s VFO from  A to B.  I have to manually switch it back to VFO A.  Once back on  A, it does stay on A after band/mode changes.  Don’t know if anyone else is seeing this but it occurs at every launch.

IC-7300:  When WSJT-X launches it will randomly switch the 7300’s VFO from A to B then back again to A.  This occurs quickly and usually only occurs every 5 or 6 launches of WSJT-X.  Not so much a problem on the 7300 as on the 9700 but noteworthy none-the-less.

 

I run two rig specific instances of WSJT-X.  My hardware/software setup hasn’t changed in a very long time and no recent windows updates or changes have occured.  I can only think this is a Hamlib issue but was wondering if others are seeing the same thing.   Is there a location/file that logs what’s being sent from WSJT-X to the rig when launched I can look at ??  I may have another way to extract some of what is being sent but was hoping WSJT-X was logging to some system file when launched.

 

Thanks for any help,


There is some work going on to identify these problems and fix them.

See https://github.com/Hamlib/Hamlib/commits/master and look at the recent commits.

Once it is all sorted out I think there will be a hamlib-4.2.1 bugfix release and the WSJTX guys will provide updates too.

HTH

-- 

Brian  G8SEZ
 

Join main@WSJTX.groups.io to automatically receive all group messages.