locked Re: Installing WSJT 2.4.0-1 #linux #install


Bill Somerville
 

On 31/05/2021 13:00, JD Delancy wrote:
I upgraded my Linux box to Fedora 34 (from 33) and then tried to upgrade the WSJTx to the General Availiablity release WSJT-X 2.4.0

It would not load, and the following error appeared:
  - nothing provides libboost_chrono.so.1.73.0()(64bit) needed by wsjtx-2.4.0-1.x86_64
  - nothing provides libboost_date_time.so.1.73.0()(64bit) needed by wsjtx-2.4.0-1.x86_64
  - nothing provides libboost_filesystem.so.1.73.0()(64bit) needed by wsjtx-2.4.0-1.x86_64
  - nothing provides libboost_log.so.1.73.0()(64bit) needed by wsjtx-2.4.0-1.x86_64
  - nothing provides libboost_system.so.1.73.0()(64bit) needed by wsjtx-2.4.0-1.x86_64
  - nothing provides libboost_thread.so.1.73.0()(64bit) needed by wsjtx-2.4.0-1.x86_64
  - nothing provides libboost_atomic.so.1.73.0()(64bit) needed by wsjtx-2.4.0-1.x86_64
  - nothing provides libboost_log_setup.so.1.73.0()(64bit) needed by wsjtx-2.4.0-1.x86_64
  - nothing provides libboost_regex.so.1.73.0()(64bit) needed by wsjtx-2.4.0-1.x86_64

I tried the --skip broken files suggested by the system; no good

What now?
Hi JD,

our production system is still on Fedora 33, it will probably be upgraded for the upcoming WSJT-X v2.5.x releases. You should either build from sources, or wait for our RPM style package maintainer to publish v2.4.0 GA packages.

73
Bill
G4WJS.

Join main@WSJTX.groups.io to automatically receive all group messages.