locked Re: Import Hamlib #Cat_RigControl


Bob
 

After upgrading to WJSTx2.4.0, I am getting a HAMLIB error on PTT now.  Worked OK with 2.3.1 and 2.4.0-rc4.  No settings changed.  W10/64 up to date, Ryzen 7 PC, Flex 1500 running Power SDR 2.7.2. I have 3 identical stations on 2m, 222 and 432 for terrestrial and EME.  2m and 432 still at 2.3.1 and with the upcoming VHF contest, I don't want to mess with them unless I can fix it on this 222 station, other than going back to 2.3.1.  I run VAC and VSP mgr. 
In 2.4.0, I get green TestCAT but Red TestPTT and HAMLIB error shown below and TestCAT turns Red.  Click TestCAT again and it will return to green but PTT again will produce the error.  I saw one note on this thread where someone suggested changing radio setting in WSJTx to USB.  I must have Flex in DIGU to use VAC.  I did try with USB.  No error but also no PTT.  Any help appreciated.  I would be OK for the upcoming contest using 2.3.1 but eventually want to get 2.4.0 going to have access to Q65 for EME as I have seen a number of stations using it already.  I also saw some chatter about hamlib now as a DLL file and I see that in the 2.4.0 install directory but don't know if it actually works from there.  I don't know where it should go if it would be of help.  Thanks and 73, Bob

Join main@WSJTX.groups.io to automatically receive all group messages.