locked Re: WSJT-X Crashing on transmit #wsjt-x-crashing


Bill Somerville
 

On 13/04/2021 12:28, Panther 353PA wrote:
I am running WSJT-X on a Raspberry Pi 400. This error occurs on both 2.3.1 and 2.40.-rc4 versions with Hamlib 4.1 installed. I am using a USB data cable with a ferrite and about 5 turns through it and an IC-705. I use the same cable on my Macbook without issue. Less than five seconds into transmit the application crashes with no message and the radio is stuck in transmit mode. From the WSJT-X log I found the following;

[SYSLOG][2021-04-13 02:14:17.304476][00:00:11.327444][error] handle_transceiver_failure: reason: Hamlib error: Command rejected by the rig
rig.c(1488):set_cache_freq return(0)
rig_set_vfo: return -9, vfo=VFOB
rig.c(2516):rig_set_vfo return(-9) while exchanging VFOs
[RIGCTRL][2021-04-13 02:14:17.305876][00:00:11.328842][error] error: Command rejected by the rig
frame.c(355):icom_transaction return(-9)
icom.c(3661):icom_set_ptt return(-9)
rig.c(2650):rig_set_ptt return(-9)
[SYSLOG][2021-04-13 02:14:29.470977][00:00:23.493949][warning] Detected dropped audio source samples: 2,064 (0.043 S)
[SYSLOG][2021-04-13 02:14:43.297421][00:00:37.320392][info] Log Finish
I am stumped. Thoughts?

OM,

so I can see what is happening put the attached file into your WSJT-X configuration files directory (~/.config/), restart WSJT-X, do the minimum steps to reproduce the issue, then quit WSJT-X. There will be a new file on your Desktop called WSJT-X_RigControl.log , send me (g4wjs <at> classdesign <dot> com) that file for analysis please?

Once you have sent the log file delete the log file and the log configuration file to return to normal operation.

73
Bill
G4WJS.

Join main@WSJTX.groups.io to automatically receive all group messages.