Re: Sudden blindness to sound card and ports windows 10 #AudioIssues #Cat_RigControl #BugReport


Chris
 

Com ports are also affected.  Basically all I/O is broken.  MixW4 works fine and I can make FT8 contacts with it.  Last week, wsjt-x was working fine.

The interface to the rig is serial via a rig blaster.  The sound card s a C-Media on the PCI bus (not USB).Again, other programs work fine with it.

Attempting to re-configure, before I click on the pick list the correct card is shown, but if I expand the list, that card disappears and the only card showing is the default (there should be over 3 devices) and even the default does not work.

The com ports show up and are set correctly, but they throw the error when we try to test the CAT function.

The only thing that changed since last week was a Windows update.  I've rolled that back but still no joy.

I need help, but please don't give me all the stock questions and answers! I'll say it again: EVERY OTHER PROGRAM WORKS CORRECTLY WITH ALL DEVICES. Sorry for shouting, but I need to make that perfectly clear.Wsjt-x worked correctly last week.

I have uninstalled and re installed wsjt-x more than once. I've cleaned the registry, and I even did a search and destroy on all wsjt-x registry entries.  This is a strange one guys.  If the developers are listening, is there any API that wsjt-x calls that might not be needed by other programs? Oh, and I also ran system file checker and it reported no issues.

Chris, AB6QK

Join main@WSJTX.groups.io to automatically receive all group messages.