locked Re: Dependency is not satisfiable: libgfortran3 (>= 4.8.2)


Bill Somerville
 

Hi Dale and Jeff,

that is correct and they seem to prefer new packages rather often, I assume because of breaking changes as the Fortran language evolves. I have tried to include alternatives in the Debian and RPM control file requirements for the next release. Unfortunately there is a defect in the dependencies listed for WSJT-X v2.3.0 RC1, the next release will be better.

Note that the Debian package we release for WSJT-X v2.3.0 RC1 targets Debian 10 (Buster) based distribution versions like Ubuntu 20.04. As Rick notes, building from sources is the right way to go if there are dependency issues. I don't understand why anyone would consider importing packages not in the mainstream distro repositories, that is risking breaking any number of other packages whereas building WSJT-X from sources will never require any packages not in your current distro repositories.

73
Bill
G4WJS.

On 02/11/2020 10:30, Rick Chapman wrote:

Jeff

I think you are mistaken.  libfortran3 and libfortran5 are different packages, so libfortran5 can never satisfy a dependency on libfortran3.

Dale

If libfortran3 is not in your repository, you can (should) build WSJT-X from sources.  Download the wsjtx-2.2.2.tgz file and read the install file it contains.

Build from sources is pretty easy but there are some fairly obvious typos in the install file.

Where it refers to "SVN" this may be in your repository as "subversion"

"libqt5libserialport5-dev"  should be "libqt5serialport5-dev"

"libusb-1.0.0-dev"  should be "libusb-1.0-0-dev"

Also prior to running the line "$ tar xzf wsjtx-2.0.0.tgz" which should be "$ tar xzf wsjtx-2.2.2.tgz" you need to have copied the tgz file into the build directory

Also "cmake -DWSJT_SKIP_MANPAGES=ON -DWSJT_GENERATE_DOCS=OFF ../wsjtx-2.0.0"  should end with 2.2.2 as well

Also be aware at the line "$ cmake --build ." this ends with a dot which is important.

The tools and libraries were about 300Mb to download  Build will take a few minutes to complete.  This approach will get round all your dependency problems.

Hope this helps

Rick(GM4JIB)


On 02/11/2020 02:45, Jeff Stillinger via groups.io wrote:
Read your error message  " wsjtx depends on libgfortran3 (>= 4.8.2); however: "

The ">=" is the mathematical symbol for equal to or greater than.   Therefore, libgfortran5 is greater than 4.8.2 and should meet the dependency.


On 11/1/20 12:22 PM, Dale Coleman wrote:
On Sun, 2020-11-01 at 10:46 -0600, Jeff Stillinger via groups.io wrote:

Thanks for the reply. I'm confused over libgfortran3 vs libgfortran5
and the required version.

Looks like libgfortran5 is avaiable but not libgfortran3

root@BlackBox:/home/dkc# apt-cache search libgfortran5
libgfortran5 - Runtime library for GNU Fortran applications
libgfortran5-dbg - Runtime library for GNU Fortran applications (debug
symbols)
libgfortran5-amd64-cross - Runtime library for GNU Fortran applications
libgfortran5-arm64-cross - Runtime library for GNU Fortran applications
libgfortran5-armel-cross - Runtime library for GNU Fortran applications
libgfortran5-armhf-cross - Runtime library for GNU Fortran applications
libgfortran5-i386-cross - Runtime library for GNU Fortran applications
libgfortran5-mips-cross - Runtime library for GNU Fortran applications


Join main@WSJTX.groups.io to automatically receive all group messages.