locked Re: Hamlib error: Protocol error while testing getting current VFO


Bruce N7XGR
 

Randy,  As Neil has pointed out that some Hamlib files are incorporated within the dot exe
of WSJT-X then that is where the problem begins.  Instead of the files being within WSJT-X
it would be better to have the necessary Hamlib files in another location that can be easily
updated and separate from the dot exe.  Like this location,
C:\Users\YourName\AppData\Local\WSJT-X\Hamlib
The Hamlib folder is where all necessary files are there and can be easily updated.
One would copy the entire Hamlib folder to another location for safe keeping just in case
and then copy/paste the updated Hamlib files into the Hamlib folder then start WSJT-X
and in your case select the correct radio (FT817) in the dropdown.
WSJT-X can be setup to read from this Hamlib folder the required files for the operation.
I fully realize that some people will criticize this idea but it will most definitely solve the bugs
that Hamlib unleashes by simply being able to update manually with files that have been fixed.
As it stands now the only way for any updated Hamlib version to be contained in WSJT-X
is to put out a new WSJT-X version.  If a new radio comes out then the Hamlib team
incorporates this and comes out with a version that includes the new radio, copy this new
version into the Hamlib folder--no need to update the entire WSJT-X.
Of course a new WSJT-X version will be needed too, as I said earlier read from the
Hamlib folder the required files, from then on just update the Hamlib folder.
It is crazy for people to select a different radio in order to stop the rig error popup.
I am now donning my Kevlar suit just waiting for the licking of the flames!!!

Bruce  N7XGR 


On Thu, Jul 30, 2020 at 11:35 PM neil_zampella <neilz@...> wrote:

FWIW ... the latest version of Hamlib is compiled in with WSJT-X.

As far as earlier versions, they are always available on Sourceforge here:  https://sourceforge.net/projects/wsjt/files/

Neil, KN3ILZ

On 7/30/2020 9:00 PM, Randy Mönch wrote:
I share your pain.  I have Hamlib blues with my 817 since upgrade from 2.1  I see that FLdigi says it is using Hamlib 4.0.  When selecting rig with new version of FLdigi it has FT-818.  I have search for Hamlib 4.0 and can not find it on the web yet is has the FT818.  Could this mysterious version of Hamlib solve the problems with the latest version of WSJT-X? I would like to go back to WSTJ-X 2.1 but cannot find a downloadable file.

Randy - KE0RXF

    

Virus-free. www.avg.com

Join main@WSJTX.groups.io to automatically receive all group messages.