locked Re: #bug #macos #hamlib #wsjtx #thank #IssueReport


Miloš Soukup
 

Hi Bill,

It is my file.

Thx & 73 de Miloš, OK1FMY


Hi Miloš,

as far as I can see that settings file should have made the FT-857 Hamlib rig model behave as the FT-817 rig model did in previous versions. Can you send the file as you created it as an attachment so I can check the contents please?

73
Bill
G4WJS.

On 06/07/2020 09:07, Miloš Soukup wrote:
Hi Bill,

I stored the json file to:
C:\Users\Miloš\AppData\Local\WSJT-X
and it did not help.

I can use my HS1 with 2.1.2 and my FT-817 with 2.2.2.
I can do with it.

Tnx and 73! de Miloš, OK1FMY


Hi Miloš,

unfortunate coincidences when things are not working are all too common, sorry you had a triple hit!

The mcHf and similar rigs will occasionally work with the Yaesu FT-857 model, it is a timing issue that is resolved in the FT-817 Hamlib model by extra retries, but because of a Hamlib breakage that model is not available to you until the next release. Please try creating a file in the WSJT-X log files directory called hamlib_settings.json with the following contents:
{
    "config": {
    "retry": "5",
    "timeout": "3000"
    }
}
and see if that helps when using the Yaesu FT-857 model with your Ailunce HS1 rig.

73
Bill
G4WJS.

On 03/07/2020 16:08, Miloš Soukup wrote:
Hi Bill,

I am sorry for the delay.
I was fighting three issues simultaneously:
1. Update to WSJT-X 2.2.2.
2. HW defect - the 3.5mm Jack I use for connecting to my external USB sound card became an "insulator".
3. My cellphone updated to Android 10 and the app by IZ2BKT I use for syncing time over bluetooth stopped working.
All the three things happened nearly at the same day.
I was not able to transmit anything. I blamed 2.2.2 but it was caused by the connector.

I can summarize my results related to WSJT-X:
1. My FT-817 works with 2.2.2 as FT-857.
2. I have my second rig: Ailunce HS1 - another Chinese cousin of mcHf by M0NKA. 
HS1 works as FT-817 with 2.1.2 but refuses to work with 2.2.2 as FT-857.

73! and tnx de Miloš, OK1FMY


Hi Miloš,

are you still having issues with your rig using the FT-857 model on v2.2.2 of WSJT-X?

73
Bill
G4WJS.

On 26/06/2020 04:01, Miloš Soukup wrote:
Hello Bill,

Thank you for your info.
Pls, which is the last version not affected by it? 2.2.0?

thx & 73 de Miloš, OK1FMY


On 25/06/2020 17:11, Miloš Soukup wrote:
>
> Hello Bill,
>
> I have the same problem with FT-817. I returned to 2.1.2 - it works
> for me fine. Should I select FT-857 also?
>
> tnx & 73 de Miloš, OK1FMY
>
Hi Miloš,

Glenn's issue was slightly complicated because he is not using a real
FT-817D but a UbitX rig that uses an FT-817D protocol. In your case the
FT-857 rig option should work OK.

73
Bill
G4WJS.



Join main@WSJTX.groups.io to automatically receive all group messages.